Page 1 of 7 123 ... LastLast
Results 1 to 10 of 62

Thread: audiofix

  1. #1
    Join Date
    Feb 2007
    Location
    NSW
    Posts
    99

    audiofix

    Hi all,
    I have developed a script which attempts to fix the audio issues people are experiencing on some channels. The issue is that some channels are now broadcasting 2 audio streams. One of these cannot be decoded sucessfully by the TiVo. It also seems to be selected as the default stream when you change channels. The result is either no audio, squeaks etc on the audio, and in some cases no video. This would probably be easy to fix if the Tivo was still supported, but of course it isn't. So we have to find ways around the problem. So, I spent a a considerable amount of time analysing the problem and have developed a script which seems to fix the issue. It works by listening for channel change events, and then selecting the English audio stream if multiple streams are detected. In testing so far it is working well for both live TV and recordings, but to date it as only been tested by a handful of people. I have been running it for over a month now without any issues.

    The next stage is to automatically roll this script out to whoever wants/needs it. For most people this should be an automatic process. I'd like a few more people to test this before making it widely available. To date, I have installed it on 4 tivos, it has been manually installed on 2 or 3 others, and automatically installed on 2.
    I'm still waiting for feedback from some of the testers, so I'm asking for an additional 2 or 3 volunteers to by guinea-pigs for the automatic roll out. All you need to do is send me your Tivo service number (via private message) and I'll schedule your Tivo for an update.
    For this to work, you must:
    1) have the audio problem
    2) have a tivo with auto update running (this should all but the very early modified Tivos)
    3) be willing to give feedback on the process
    4) be prepared to take the risk that it may brick your tivo (low risk, but still possible. If this happens you may need to get some one to pull the disk to fix the issue)

    If you are willing to give it a try, please send me a PM with your TSN.

    If you feel more comfortable waiting until it has been more thoroughly tested, then please be patient and wait until it is ready for general roll out.

    Matt

  2. #2
    Join Date
    Apr 2005
    Location
    New Zealand
    Posts
    264
    In respect of the brick potential it would be wise for those with a functional MAK to image their drive before they try the script.

  3. #3
    Join Date
    May 2004
    Location
    Victoria
    Posts
    1,230
    That’s great work. I’ll update my website FAQ section shortly to point to this thread rather than the other one, and alert those who have asked me via email.
    Darren King
    OzTiVo Repairs and Modifications
    If your TiVo requires repairs or modifications
    then visit: http://kingey1971.wix.com/tivorepairs

    NOW ALSO REPAIRING FETCH TOO!

  4. #4

    Problems with sound.

    Quote Originally Posted by MattCallow View Post
    Hi all,
    I have developed a script which attempts to fix the audio issues people are experiencing on some channels. The issue is that some channels are now broadcasting 2 audio streams. One of these cannot be decoded sucessfully by the TiVo. It also seems to be selected as the default stream when you change channels. The result is either no audio, squeaks etc on the audio, and in some cases no video. This would probably be easy to fix if the Tivo was still supported, but of course it isn't. So we have to find ways around the problem. So, I spent a a considerable amount of time analysing the problem and have developed a script which seems to fix the issue. It works by listening for channel change events, and then selecting the English audio stream if multiple streams are detected. In testing so far it is working well for both live TV and recordings, but to date it as only been tested by a handful of people. I have been running it for over a month now without any issues.

    The next stage is to automatically roll this script out to whoever wants/needs it. For most people this should be an automatic process. I'd like a few more people to test this before making it widely available. To date, I have installed it on 4 tivos, it has been manually installed on 2 or 3 others, and automatically installed on 2.
    I'm still waiting for feedback from some of the testers, so I'm asking for an additional 2 or 3 volunteers to by guinea-pigs for the automatic roll out. All you need to do is send me your Tivo service number (via private message) and I'll schedule your Tivo for an update.
    For this to work, you must:
    1) have the audio problem
    2) have a tivo with auto update running (this should all but the very early modified Tivos)
    3) be willing to give feedback on the process
    4) be prepared to take the risk that it may brick your tivo (low risk, but still possible. If this happens you may need to get some one to pull the disk to fix the issue)

    If you are willing to give it a try, please send me a PM with your TSN.

    If you feel more comfortable waiting until it has been more thoroughly tested, then please be patient and wait until it is ready for general roll out.

    Matt
    Hi I have problems with sound and picture with ABC ch's 22, 23, 24 etc and the racing ch. I have 3 Tivos connected to two different aerials. Some times there will be sound and no picture and other time picture and no sound all other ch's are perfect as is ABC 2. A relative is also having the same problems.
    If I can help in anyway I'll be glad too.
    I told Darren about it and asked if he knew what was causing this problem a few weeks ago.

    Robert.

  5. #5
    Quote Originally Posted by MattCallow View Post
    Hi all,
    I have developed a script which attempts to fix the audio issues people are experiencing on some channels. The issue is that some channels are now broadcasting 2 audio streams. One of these cannot be decoded sucessfully by the TiVo. It also seems to be selected as the default stream when you change channels. The result is either no audio, squeaks etc on the audio, and in some cases no video. This would probably be easy to fix if the Tivo was still supported, but of course it isn't. So we have to find ways around the problem. So, I spent a a considerable amount of time analysing the problem and have developed a script which seems to fix the issue. It works by listening for channel change events, and then selecting the English audio stream if multiple streams are detected. In testing so far it is working well for both live TV and recordings, but to date it as only been tested by a handful of people. I have been running it for over a month now without any issues.

    The next stage is to automatically roll this script out to whoever wants/needs it. For most people this should be an automatic process. I'd like a few more people to test this before making it widely available. To date, I have installed it on 4 tivos, it has been manually installed on 2 or 3 others, and automatically installed on 2.
    I'm still waiting for feedback from some of the testers, so I'm asking for an additional 2 or 3 volunteers to by guinea-pigs for the automatic roll out. All you need to do is send me your Tivo service number (via private message) and I'll schedule your Tivo for an update.
    For this to work, you must:
    1) have the audio problem
    2) have a tivo with auto update running (this should all but the very early modified Tivos)
    3) be willing to give feedback on the process
    4) be prepared to take the risk that it may brick your tivo (low risk, but still possible. If this happens you may need to get some one to pull the disk to fix the issue)

    If you are willing to give it a try, please send me a PM with your TSN.

    If you feel more comfortable waiting until it has been more thoroughly tested, then please be patient and wait until it is ready for general roll out.

    Matt
    Thanks, Matt. PM sent.

  6. #6
    Join Date
    Feb 2007
    Location
    NSW
    Posts
    99
    There are now eight people who have agreed to help test the automatic update. Of those, two have reported that it works, four are scheduled for update tonight, and I'm waiting for feedback from the remaining two.
    I don't need anyone else to test the update process for now. If these updates all work, I will make it generally available.
    I will post further updates here.

    Matt

  7. #7
    Join Date
    Feb 2007
    Location
    NSW
    Posts
    99
    Six of eight updates confirmed working. Waiting for feedback on the last two.

  8. #8
    Join Date
    Feb 2007
    Location
    NSW
    Posts
    99

    Audiofix Rollout

    All eight testers have reported that the fix has worked, with no issues during the automatic update. So I think it's time to roll this out to whoever wants it. In most cases, I can schedule this automatically. To do this, you need to send me your Tivo Service Number TSN.
    To find your TSN:
    From TiVo Central, select 'Messages & Settings' -> 'Account & System Information' -> 'System Information'
    The TiVo Service Number (or TSN) is the number starting with 663-

    Send me this number via email to mc682001-audiofix@yahoo.com (make sure that you put audiofix in the subject). I will then schedule your Tivo for an update. The update will occur overnight. If the update worked, your TiVo will be restarted and you should get a new message:
    update message.jpg
    When audiofix is running, you should see a banner in the top left of the screen when in TiVo Central:
    audiofix running.jpg

    Feel free to publish the email address elsewhere for people who do not read this forum.
    Note: Please use the email address above and not forum private messages. The forum PM system is awkward to use for this purpose.

    Matt
    Last edited by MattCallow; 19-01-2021 at 10:14 PM. Reason: No longer accepting PMs for update

  9. #9
    Join Date
    Aug 2005
    Location
    Melbourne, VIC
    Posts
    12
    Great news Matt. Thanks for persevering with this. Cheers.
    Regards, Martin.

    Modded - TivoHD 160 (1TB) HNP

    Had...
    Defunct - S1 Tivo, 120Gb, Turbonet card, FOXTEL Digital Cable, UEC STB
    Defunct - S1 Tivo, 40Gb, Turbonet card, Analogue FTA, NEC VCR

  10. #10
    Brilliant work Matt - PM sent - thank you.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •