Hi, I have a New Zealand TiVo that was converted over in November and received guide data correctly up to 29 December. Since that date, the connection to the TiVo service fails at "Negotiating the connection", with a "N17" error message.

If I go to the Network Diagnostics and choose Tivo Service connection, this succeeds, but of course gets no guide data.

The DialInCode is 140 and the country is NZ.

I've tried restarting several times, and also tried connecting from a friend's house (the person who converted my Tivo) with a different ISP.

Other things I've tried include "Clear program information & To Do list" and checking the file space (telnet into the tivo and used the df command) which seems ok.

A couple of weird things I've observed are:

1. The time on my Tivo is 2 hours out (in the past). I tried manually setting the time using settime, but connecting to the Tivo service still failed and afterwards the time was set back again. I did notice in the tclient log file that "timeZoneOffset" is 36000 (10 hours) - should be 13 hours for NZ.

2. Looking through the log files, most of those starting with "O" end shortly after 5:30 am (UTC) on the 29th of December which was the time of the last successful connection so something seems to have made the Tivo roll its logs at that time.

Below is an extract from tclient showing a failed connection attempt:

I'd appreciate any ideas on what could be going wrong or pointers on where to look in the log files.