Results 1 to 2 of 2

Thread: Help! My Tivo has died!

  1. #1

    Help! My Tivo has died!

    I went to check the Tivo this morning and noticed no Green LED on front of unit.
    Switched on TV and no output on screen.
    Pulled out power and re-connected and hear hard drive spinning up,then nothing.
    There was a power failure in our area last night like most of Melbourne was encountering.

    I've disconnected it and now sitting on bench.
    What to do next?

    Thanks

  2. #2
    Join Date
    May 2004
    Location
    Victoria
    Posts
    1,218
    If you keep the power supply plugged into the motherboard (it needs a load to function) you can use a multimeter to test the two voltages it produces:

    Yellow/black wires will show roughly 12 volts DC
    Red/Black wires will show roughly 5 volts DC

    When I say "roughly" I mean +/- 10% for tolerances. It won't be "spot on" the two figures quoted but near enough is good enough.

    If you have these then it is most likely the motherboard.
    Darren King
    OzTiVo Repairs and Modifications
    If your TiVo requires repairs or modifications
    then visit: http://kingey1971.wix.com/tivorepairs

Similar Threads

  1. tivo just died
    By j30max in forum Australian TiVoHD
    Replies: 12
    Last Post: 02-04-2010, 08:43 AM
  2. My Tivo has died
    By CParrill in forum Australian TiVoHD
    Replies: 8
    Last Post: 14-03-2009, 09:15 PM
  3. I think HDD has died
    By wbeasley in forum New Zealand General Forum
    Replies: 11
    Last Post: 03-10-2007, 03:38 PM
  4. TEAC 420 STB Died
    By batta in forum Question and Answer Forum
    Replies: 1
    Last Post: 28-02-2007, 02:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •