Results 1 to 2 of 2

Thread: TiVo freezes with purple 'filter' effect over picture. Any ideas?

  1. TiVo freezes with purple 'filter' effect over picture. Any ideas?

    Hi everyone. This is my first post but have been a TiVo user for a while now, having a series 1 in the good old days!

    I have an intermittent issue with my TiVo series 3 that i am struggling to pin down. Model number is TCD663160 running software 11.3b8-01-2-663. I bought the unit new and replaced the 160GB hard drive with a 1TB drive straight away. That drive has been working fine for many years up until recently. My Tivo is connected via HDMI to a Denon AVR-2309 receiver, which is connected to the TV via HDMI as well. I have tried the AV receiver in video pass through mode as well as upscaling to 1080i mode and neither seem to make a difference. Tivo is currently set to Fixed 1080i

    The problem (or problems) ’seem’ to involve intermittent freezing and rebooting when I am watching the TiVo. The show will stutter a bit then freeze, then the unit reboots and everything is fine again (after it reloads the guide data). I also know that spontaneous reboots occur when i’m not watching as I have had a number of partial recordings and can see by the network settings that the last service call occurred just after the break in the partial recording.

    At other times, I will switch on the TV to watch something and the picture will appear frozen with a 'purple filter' over it (see attached image). In these cases there is no response from the remote and I have to hard reset the box (i.e. pull the power cord) to get it to restart. There does not seem to be any pattern to when this happens but the purple screen only ever appears when the TV and AV receiver have been switched off (by off i mean in the normal standby mode not unplugged) and I switch it on to watch something. I can sometimes force this to happen by switching the TV off then back on while the Tivo is booting up.

    So after looking at many forum posts on here, i thought it was my hard drive. So i recently replaced it with a new WD 1TB red drive. I made a truncated copy of my old 1TB drive in an attempt to save my settings etc, but didn’t attempt to MFScopy the old 1TB drive to the new one. When i put the new drive in the tiro, it booted to the green screen of death which i had never encountered before. I let it do its thing and it rebooted fine after a while and seemed to be working but then I had the same spontaneous reboot problem again.

    I then ran the kickstart hard drive test and the drive came up as passed, so i thought it might be corrupted software (which I read in one of the posts on this forum). I just happened to have a truncated copy of a friends tiro that i had recently upgraded to the same type WD drive. I restored my drive with this truncated copy then performed the clear everything and delete function to get it to work. During this operation I switched the TV off (to avoid burn in) and when i switched it back on to check the progress, i had the purple filter problem and had to pull the plug. It booted again and then continued the clear and delete which seemed to work fine but within 48 hours I have had both problems again.

    I also tried connecting directly to the tv via component cables while it was frozen with the purple screen to see if it was only a hdmi output thing, but the screen was still frozen and purple over component.

    So thats where i am at, i’m still not sure what is going on. I think the new hard drive is fine. From reading other posts I think it may be a problem with the HDMI ‘handshake’ procedure, the port itself or perhaps a dodgy video encoder chip like in this post (

    Any help or advice would be much appreciated

    kind regards
    Attached Images Attached Images

  2. #2
    Join Date
    Dec 2005
    Christchurch, New Zealand
    Hi Brad, it's been a while since I visited the forums. I'm wondering if you got the issue sorted?
    I fixed a TiVo that had a spontaneous reboot problem by replacing the capacitors on the power supply.
    Here's a thread regarding the capacitors
    Cheers, John
    Last edited by Skolink; 11-04-2015 at 08:09 PM. Reason: Added link

    TiVo Series3 TiVoHD x2

Similar Threads

  1. Connect TIVO to Sony Bravia TV Problem Any ideas??
    By Bille in forum Australian TiVoHD
    Replies: 6
    Last Post: 30-08-2011, 10:43 PM
  2. Thomson Tivo, No Video... any ideas?
    By BenMorgan in forum New Zealand General Forum
    Replies: 6
    Last Post: 18-02-2009, 07:15 PM
  3. I'll probably be shot.. but moving to Aus with my TIVO! Any ideas?
    By tatch76 in forum New Zealand General Forum
    Replies: 15
    Last Post: 10-11-2008, 05:21 PM
  4. Tivo Freezes on Startup..
    By star in forum Question and Answer Forum
    Replies: 5
    Last Post: 22-02-2007, 04:29 PM
  5. Tivo freezes at start up
    By Phil_C in forum Question and Answer Forum
    Replies: 13
    Last Post: 02-09-2005, 06:53 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts