Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: TiVo HNP Problem

  1. #11
    Looks like the devices are on different subnets, 192.168.0 and 192.168.1
    You will still be able to access the web server on the Tivo from the PC but non-routeable packets won't make it through, hence the Tivo and PC won't see each other.

    Where are the two devices getting their addresses from? Does your router or ADSL/cable modem provide the addresses via DHCP? Or do both do that, hence the confusion? Or have one or both of the Tivo and PC addresses been set manually?

    Either way, until they are the same subnet you won't have much luck.

    If you have a modem and router running DHCP try disabling it on one of them and power down and restart everyting.

    If you have only one device running DHCP check the settings to make sure the range of addresses makes sense, ie starting address something like 192.168.x.0, the number of addresses something like 32 (should be enough for a home network) and subnet mask

    After making any changes it is really important to power down everything. It shouldn't make a difference but just to be sure try powering up the modem/router running DHCP followed by the other devices a minute or so later. Then check what addresses each of the devices, Tivo and PC, has been assigned. If they are on the same subnet then you are in with a chance.

    If that doesn't work then it might be worth running through exactly how things are connected, ie what is plugged in to what, which devices are wired v. wireless, etc.
    Last edited by JohnScott; 28-03-2009 at 03:23 PM.

  2. #12

    Thumbs up

    Thanks JohnScott. It has been a steep learning curve and you know, I thought I knew a bit about computers. I will explain the lot so far...
    I have NIS 2009 on Vista Home Premium. My PC is hooked to a Lynksys 3102 ATA, the Linksys ATA is hooked to the ADSL phone line. The ATA is then hooked to the wireless NB6Plus4W ADSL modem. The modem is hooked to the PC and wirelessly to the TiVo.
    I now fixed my PC IP address 192.168.0.xx as per and fixed the primary and secondary DNS server addresses as well.
    (I don't understand gateways, IP's, DNS, DHCP or ports very well)
    I then went to the > advanced > Virtual Server > Port Forwarding menu of the NB6Plus4W and port forwarded all of the TiVo ports to my PC's fixed IP address.
    I then went to the > advanced > Router > Application menu of the Linksys 3102 ATA and port forwarded all of the TiVo ports to my PC's fixed IP address.
    I then went to the > Internet > Settings > Smart Firewall > Advanced Settings > Configure > General Rules > Configure menu of NIS 2009 and allowed local and remote TCP and UDP communication to and from any computer for all of the TiVo ports.
    I then ensured that windows > Task Manager > Services... > Bonjour Service was 'started' and had a startup type of 'automatic'.
    I still could not connect. I changed the DMZ settings on the ATA and modem to forward all ports to my fixed IP address.
    I still could not connect. I decided to disconnect the Linksys ATA to isolate that from the equation. I couldn't get the internet back on line though and reversed this action. This is when my daughter yelled out that there was a message on the TiVo saying "Congratulations...blah, blah"
    I had applied all changes as I went but I had not restarted the ATA or the modem. When the internet was disconnected / reconnected, it must have restarted the system, applied the firewall rules and the portforwarding. I am not sure which worked.
    Disconnecting the internet to get it to work seems a pretty basic thing that I should have tried on day 1. I am now not certain that all of the other port forwarding and fixing the IP address means anything at all.
    What do you think.
    Thanks for the help JohnScott. I know you have put some thinking into this as well and I appreciate it.

  3. #13
    Guess what!
    It stopped working again with the same symptoms described in this post:

  4. #14
    Everyone is always learning so don't feel left out.

    I think the port forwarding probably isn't key to the result - if the devices are on the same subnet then port forwarding is not relevant. It may be needed for some Tivo features involving the outside world but I have none of the ports recommended by Tivo support forwarded to the device, and everything except the Tivo port configuration test works fine - that's consistent at least. Until they document in more detail what the ports are for I plan to leave it that way.

    I'm not familiar with the 3102 but I am guessing it was providing the DHCP address to your PC while the NB6Plus4W was providing the address to the Tivo, and they were set up to issue addresses on different subnets. One solution would be to set them up to provide addresses in the same subnet, ie both 192.168.0 or 192.168.1 but with different starting points and ranges that do not overlap, but that's a bit of a kludge.

    At the moment your PC is traversing two devices (3102 and NB6Plus4W) in order to reach the outside world. It would be better if it were one. If it was my set up I would have the 3102 and PC both connected to the router, along with the Tivo, and I would disable DHCP on the 3102. The 3102 VOIP setup might need some work - check out the link below which I think describes your situation:

    Restarting everything is always a good idea, otherwise the debugging process has too many variables to deal with.

    Disconnecting the 3102, and plugging the PC straight in to the router was a sensible thing to try (as long as you rebooted of course as you would then need to get an IP address from the router).

    I am 90%+ confident that the subnet issue was the problem as it is documented in a few places. I tried a little recabling of my setup to put the Tivo and PC on different subnets and while both the Tivo and PC could reach the outside world, and the PC could reach the web page on the Tivo (a routeable protocol) the Tivo Desktop software on the PC could not see the Tivo as it uses a multicast, non-routeable protocol only ever intended to be used on the local subnet.

    Glad to hear it is working - guess you now have to wonder if the changes made will break something else. That's half the fun of networking ...

    Last edited by JohnScott; 29-03-2009 at 11:47 AM.

  5. #15
    Guess I spoke too soon about it working. Could it bethe wireless connection fading in and out? Running a cable from the router to the Tivo, just as a temporary measure, should answer that question pretty quickly.

  6. #16
    Hi JohnScott, I looked up the US TiVo forum and found that others are having the file transfer issue with the 2.7 software. "The system cannot find the file specified"
    You got me thinking about the need to make all the changes I had made to date and I took a gamble...
    I turned off port forwarding in my ATA and modem and removed my NIS 2009 exception rules. I downloaded the new bonjour as well.
    I then gave my setup a bit of a shake: I now have the following config:
    Phone line split into 2 lines.
    1) Goes to ATA > handset. Provides VoIP as well as fallback to PSTN.
    2) Goes to modem. Provides ADSL
    Modem > ATA, PC & TiVo (WLAN)
    ATA, PC & TiVo each have fixed IP's.
    I had to restart a few times of course.
    I then uninstalled 2.7, restarted, cleaned, restarted, turned off TiVo network applications and rebooted TiVo.
    I then reinstalled 2.7 and I think I am in business; touch wood!!

    Thanks for some good advice. I have learnt a lot and it is apparent that the more I learn, the less I know. (Sounds like a new motto for me)

  7. #17
    The TiVo Desktop software has stopped again. I downloaded one show to my PC and then it just stopped working.
    _The more I learn, the less I know_

  8. #18
    Have you tried temporarily replacing the wireless connection to the Tivo with an ethernet cable? Might help eliminate one source of problems.

Similar Threads

  1. problem transfering tivo files
    By 85turbo in forum Australian TiVoHD
    Replies: 10
    Last Post: 18-11-2010, 12:40 AM
  2. Another TiVo Desktop Problem!
    By Syntax in forum Australian TiVoHD
    Replies: 1
    Last Post: 02-04-2009, 02:38 PM
  3. Tivo Serial Problem - Please Help!!!
    By normal_kinda_guy in forum Question and Answer Forum
    Replies: 46
    Last Post: 25-06-2006, 05:51 PM
  4. TiVo time problem
    By Wanted in forum New Zealand General Forum
    Replies: 3
    Last Post: 27-01-2006, 09:09 PM
  5. Tivo Time Problem
    By sadrake in forum New Zealand General Forum
    Replies: 16
    Last Post: 10-08-2005, 06:47 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts