Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: no 5m pre ot 15m post record on shows

  1. #1
    Join Date
    Jun 2005
    Location
    Gold Coast
    Posts
    39

    no 5m pre ot 15m post record on shows

    Hey Pete, John & Darren,

    I manually deleted all my settings the other night on one of my Tivos and re did the guided setup etc to start again.

    Now all is good but for one thing. When recording it will not record 5mins before and 15 mins after etc. It will only record for the specified time for the show no matter if there if nothing to record either side of it.

    Do you know what I have to do to get this back working?

    I assume its quite easy and have searched for the answer but cant seem to find it and any help you can give me will be greatly appreciated.

    Thanks

    Craig
    Last edited by Wiked; 09-07-2006 at 12:41 AM.
    ______________________
    3 x TiVo HD [1TB HDD], HNP

    TiVo HD212 [300gb HHD, Turbocard] For Sale
    TiVo HD312 [300gb HHD, Turbocard] For Sale

  2. #2
    Join Date
    Apr 2004
    Location
    Perth, Western Australia
    Posts
    3,032
    check the endpad.log for the reason why it is not running properly.

    You could also try:

    ps ax | grep endpad*

    To see if it's running at all.

    Peter.
    Please search this forum and our Website for your TiVo questions before starting a new thread. Thanks!

  3. #3
    Join Date
    Jun 2005
    Location
    Gold Coast
    Posts
    39
    When I try

    ps ax | grep endpad*

    it comes back with:

    284 p0 SW 0:00 grep endpad*

    Sorry but I have no idea on what that means. Any ideas?
    ______________________
    3 x TiVo HD [1TB HDD], HNP

    TiVo HD212 [300gb HHD, Turbocard] For Sale
    TiVo HD312 [300gb HHD, Turbocard] For Sale

  4. #4
    Join Date
    Apr 2004
    Location
    Perth, Western Australia
    Posts
    3,032
    It means that endpad is not running.

    Did you change rc.sysinit.author ?

    How about the logs ?

    Peter
    Please search this forum and our Website for your TiVo questions before starting a new thread. Thanks!

  5. #5
    Join Date
    Jun 2005
    Location
    Gold Coast
    Posts
    39
    endpag log is:

    Friday 00:26:00 : EndPadPlus log file, log rotated
    Friday 00:26:00 : Back to sleep...
    Friday 00:26:00 : Checking every minute for kill signal...............................
    Friday 00:56:00 :
    Friday 00:56:00 : Rise and shine!
    Friday 00:56:00 : Processing current recording(s):
    Friday 00:56:00 : * No recordings in progress
    Friday 00:56:00 : Processing next recording(s):
    Friday 00:56:00 : * No scheduled recordings found
    Friday 00:56:00 : Next wake up will be 01:26
    Friday 00:56:00 : Back to sleep...
    Friday 00:56:00 : Checking every minute for kill signal......

    That time around midnight on Friday night was when I deleted all guide data and redid the guided setup etc again


    Nope, didn't touch rc.sysinit.author at all.
    ______________________
    3 x TiVo HD [1TB HDD], HNP

    TiVo HD212 [300gb HHD, Turbocard] For Sale
    TiVo HD312 [300gb HHD, Turbocard] For Sale

  6. #6
    Join Date
    Apr 2004
    Location
    Perth, Western Australia
    Posts
    3,032
    Well, for some reason endpad has not restarted since you played with the TiVo.

    Make sure you have at least 2 programs in your todo list and restart the TiVo.

    Peter.
    Please search this forum and our Website for your TiVo questions before starting a new thread. Thanks!

  7. #7
    Join Date
    Jun 2005
    Location
    Gold Coast
    Posts
    39
    Pete,

    I have about 20 programs in the todo list at any given time and actually rebooted the tivo 2 hours ago. Since then it did record a 30 min show and it still has the problem.

    Very strange indeed
    ______________________
    3 x TiVo HD [1TB HDD], HNP

    TiVo HD212 [300gb HHD, Turbocard] For Sale
    TiVo HD312 [300gb HHD, Turbocard] For Sale

  8. #8
    Join Date
    Apr 2004
    Location
    Perth, Western Australia
    Posts
    3,032
    try:

    ps ax

    This will list all processes. Then we can check if there are any others that are missing. This may point to an error loading rc.sysinit.author

    Peter.

    PS you do have endpad started by rc.sysinit.author
    Please search this forum and our Website for your TiVo questions before starting a new thread. Thanks!

  9. #9
    Join Date
    Jun 2005
    Location
    Gold Coast
    Posts
    39
    This was ps ax:

    Code:
    PID TTY STAT TIME COMMAND
        1  ?  SW   0:00 init
        2  ?  SW   0:00 (kflushd)
        3  ?  RW   0:03 (kswapd)
       58  ?  R    0:00 update (bdflush)
       66  ?  S    0:02 syslogd -p /var/dev/log -m 10000
       68  ?  SW   0:00 klogd
       78  ?  SW   0:00 bash /sbin/shondss.sh
       79  ?  SW   0:00 bash /sbin/tnlited.sh
       81  ?  RW   0:00 /sbin/tnlited 23 /bin/bash -login
       82  ?  SW   0:00 /bin/bash -login
       85  ?  SW   0:01 /tvbin/switcherstart -m -F
       86  ?  R    0:15 /tvbin/mfsd
       89  ?  S    0:00 fancontrol
      122  ?  SW   0:00 /tvbin/mcp
      153  ?  SW   0:00 tivoftpd
      155  ?  S    0:00 cron
      164  ?  R    1:29 tivosh /hack/TivoWebPlus/httpd-tt.tcl
      168  ?  SW   0:00 PipeListen
      172  ?  SW   0:00 emuProxy2 -s 131.244.9.101
      179  ?  R    0:00 trickey
      184  ?  SW   0:00 /hack/tytool/tserver
      189  ?  S    0:01 Mcp event
      190  ?  SW   0:00 /tvbin/tcphonehome
      200  ?  SW   0:00 FsMpStream
      201  ?  SW   0:00 PipeListener
      203  ?  S    0:00 PhoneHome event hd
      209  ?  S    0:00 (dhclient)
      212  ?  R    0:00 /tvbin/dbgc-mcp
      213  ?  SW   0:00 PipeListener
      214  ?  S    0:03 /tvbin/myworld
      215  ?  SW   0:00 FsMpStream
      216  ?  SW   0:00 PipeListener
      217  ?  SW   0:01 TmkSinkMixAud
      218  ?  SW   0:03 TmkClipCache0
      219  ?  SW   0:00 TmkClipCache1
      220  ?  SW   1:01 TvMomCs22Sink
      221  ?  SW   0:00 TvMomCs22Sink
      222  ?  S    0:03 Mediaswitch0
      223  ?  R    0:01 TvVideoManager
      224  ?  R    0:05 TvRecorder
      225  ?  S    0:29 TmkTaskManager
      226  ?  R    2:48 Scheduler
      227  ?  R    0:21 Prioritizer
      228  ?  R    0:02 EventLog event
      229  ?  R    0:00 PvrMain
      230  ?  SW   0:00 bus handler
      231  ?  R    4:10 ContextMgr eve
      257  ?  R    0:01 TmkClipCache: p
      261  p0 SW   0:00 /bin/bash -login
      263  p0 RW   0:00 ps ax
    All if I have referring to endpad in rc.sysinit.author is the following:

    # EndPad
    # If you want to edit the start and end, do so in /hack/bin/runendpad.sh
    /hack/bin/endpadplus.tcl 5 15 -auto


    I don't have runendpad.sh showing in the /hack/bin folder.

    I do have:
    endpadplus.README
    endpadplus.tcl
    endpadplus.CHANGELOG


    I have manually started endpadplus and will report back here to if it works but I don't know why it won't start automatically.
    Last edited by Wiked; 09-07-2006 at 05:58 PM.
    ______________________
    3 x TiVo HD [1TB HDD], HNP

    TiVo HD212 [300gb HHD, Turbocard] For Sale
    TiVo HD312 [300gb HHD, Turbocard] For Sale

  10. #10
    Join Date
    Jun 2005
    Location
    Gold Coast
    Posts
    39
    Pete,

    I started it manually by typing:

    /hack/bin/endpadplus.tcl 5 15 -auto

    and it worked with the next recording.

    I wonder why its not starting up on boot up as I have not changed the rc.sysinit.author file in any shape or form since installing TivoWebPlus some weeks ago and it has working since then after many reboots until my reguided setup. If I reboot it wont work until I manually start it up again so there must be something going on which I have no idea on.

    These are the contents of that file:

    Code:
    #### START HACKS ####
    
    export MY_SERVER=10.0.0.1
    export NFS_SERVER=$MY_SERVER
    export SMB_SERVER=$MY_SERVER
    #export TIME_SERVER=$MY_SERVER
    
    # Use extra libs (termcap, etc)
    export LD_LIBRARY_PATH=/hack/lib
    
    #### Mount Network Shares #######
    
    # mount NFS shares (if you have them) Change the NFS_SERVER variable above to the ip of box with share
    #insmod -f /lib/modules/nfs.o
    #mount -t nfs -o rsize=8192,wsize=8192 ${NFS_SERVER}:/home/tivo /hack/nfs
    
    # Mount shares on your windows boxen.
    # This doesn't work too well.
    # insmod -f /lib/modules/smbfs.o
    # smbmount //${SMB_SERVER}/SHARE /hack/smb -s putrename -c tivo -I x.x.x.x -U user -D WORKGROUP -P password
    
    #### Start Programs ######
    
    # CCXSTREAM - stream to XBOX
    # google for ccxstream or search forums at xboxmediacenter.de
    #ccxstream &
    
    # CRON # Edit /hack/etc/crontab 
    cron &
    
    #Start FTP daemon
    # this is ADH's (from Deal Database) version that saves you from chmod +x
    # 
    tivoftpd &
    
    # Start TiVoWeb
       # /hack/tivoweb-tcl/tivoweb &
       
       # Start TivoWebPlus
       /hack/TivoWebPlus/tivoweb &
    
    # Vserver - Stream ty files on port 8074 see tivo-mplayer.sf.net
    #vserver > /dev/null 2>&1 &
    
    # EndPad
    # If you want to edit the start and end, do so in /hack/bin/runendpad.sh
    /hack/bin/endpadplus.tcl 5 15 -auto
    
    ##### Various Other Hacks #######
    
    # Tweak HDD settings
    # Don't worry if you don't have a two drive TiVo. It will work for 1 drive setups too.
    # make certain runideturbo=false is in boot params, or rename
    # the file /lib/modules/ideturbo.o to something else so it doesn't load.
    hdparm -c1 -m8 -M1 -S0 /dev/hda /dev/hdb
    hdparm -m16 /dev/hda /dev/hdb
    
    # Copy Module
    # copies anything written to /var/packages to /tmp 
    # very useful for capturing tivo slices.
    #insmod -f /lib/modules/copy.o
    
    # Emu Proxy
    # A tool for cleaning up the HTTP output by the Tivo in order to pass through
    # transparent proxies, etc.
    # Works in conjunction with a small hack to the emulator to accept the header
    # "TivoURLBase" which is the base url to give back to the Tivo when specifying
    # data paths.
    # Runs by default and is dependent on the
    # 127::127.0.0.1:8000:::
    # entry in tclient.conf
    # IF YOU COMMENT THIS OUT SO IT DOESN'T RUN, YOU MUST EDIT THE "127" entry 
    # in /etc/tclient.conf to reflect the IP and port of the emulator you are using
    # There is a backup of the original here: /etc/tclient.conf-oztivo
    # Usage: %s [-d] [-h] [-l localport] [-L listenAddr] [-s serverip]
    #   [-p serverport]
    emuProxy2 -s 131.244.9.101 &
    
    # Report IP - Handy for those not using DHCP-DNS functionality
    # set dhcp hostname in /etc/dhclient.conf
    # See http://www.isc.org/ for more info on DHCP and BIND
    report_ipaddress &
    
    # Trickey by Kevin Lentin provides a way to force tivo to 
    # run commands by assign remote key sequences. Very Cool!
    # check out /hack/bin/trickey.README
    trickey &
    
    
    #Tytools
     /hack/tytool/tserver &
    Last edited by Wiked; 09-07-2006 at 08:27 PM.
    ______________________
    3 x TiVo HD [1TB HDD], HNP

    TiVo HD212 [300gb HHD, Turbocard] For Sale
    TiVo HD312 [300gb HHD, Turbocard] For Sale

Similar Threads

  1. Interesting post, I must not be the only one.
    By harrruss in forum Australian TiVoHD
    Replies: 2
    Last Post: 26-08-2009, 10:29 PM
  2. CONFIDENTIAL TV shows?
    By MrGadget in forum New Zealand TV Guide Issues
    Replies: 12
    Last Post: 15-02-2009, 07:20 AM
  3. Recorded shows
    By dyrplq in forum Question and Answer Forum
    Replies: 1
    Last Post: 23-12-2006, 02:52 PM
  4. TivoWeb – manual record module – repeat record setup bombs out
    By AJOS31 in forum Question and Answer Forum
    Replies: 1
    Last Post: 11-07-2004, 09:41 AM
  5. Favourite TV shows
    By timmy in forum New Zealand General Forum
    Replies: 3
    Last Post: 05-04-2004, 07:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •