Going into my second week of trying to get my TiVo going, I am waiting on a
wireless card which I will hope will solve my problems, but in the meantime
I would like to have another shot at getting the serialPPP going. At the
moment it fails during the downloading stage (i.e. I can connect to the tivo
via telnet and ping outside websites), I think I have established that the
ISP is ok as I can wget from other machines (but not from the tivo), plus I
can force a HTTP/0.9 connect from the Windows XP machine which I am
connecting to my TiVo. So I am thinking that the cable and the connection
speed is the problem. If I try to FTP a largeish file to the TiVo it always
stops mid-way, this is my reasoning behind a potential cable issue so I
would like to try connecting at 57600 instead of 115200.

My understanding is that there are 4 places where the connection speed is

1. Maximum Port Speed in the Modem settings
2. Port Speed in the connections settings
3. Setting the Dialling prefix in GS to ,#xxx (either 401 nomally or 257 for
4. dbsetx /State/PhoneConfig DialPrefix ',#xxx' (either 401 nomally or 257
for 57600)

If I try and set the port speed (2) and the GS dial prefix (3) I do not get
the connection to be able to telnet into the tivo and the dialup fails. The
same if I also change the dial prefix using dbset (4) I still get the same
result. In the How-to it says not to touch the max port speed (1) so I don't
change this normally although I think I may have tried it without success.

So my question is, is there something else I need to change or do, or is it
maybe that I have used the wrong combination of setting (eg 2 and 3 instead
of 1 and 4)?

Any help would be appreciated.