Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Tivoweb not starting

  1. #1
    Join Date
    May 2005
    Posts
    35

    Tivoweb not starting

    Hey tivoppl,
    Was hoping someone can help

    I have just set-up a second tivo (running oztivo 1.5) and am connecting via ppp on serial.

    My problem is that TivoWebPlus is not starting when i reboot the Tivo.
    I don't think endpad is starting either. ftp is working fine so is trickey and cron (i think that is all that gets called from rc.sysinit.author ?)

    I can start both of these manually, no problems.

    I have checked rc.sysinit and it has the correct line referencing rc.sysinit.author.

    I have check rc.sysinit.author and it looks fine, all the commands are correct, no odd spaces etc. I have even tried copying over the rc.sysinit.author from my other working tivo with no luck

    Is there something i am missing ?
    Any suggestions ?

  2. #2
    Join Date
    Apr 2004
    Location
    Perth, Western Australia
    Posts
    3,032
    First, why don't you try using V1.6 as it's the latest.

    2nd what hardware is this unit. Is it a UK TiVo ?

    Peter.
    Please search this forum and our Website for your TiVo questions before starting a new thread. Thanks!

  3. #3
    Join Date
    May 2005
    Posts
    35
    Hehe i knew you would say that, i will go to version 1.6 soon enough.

    It's a US Phillips.

  4. #4
    Join Date
    Apr 2004
    Location
    Perth, Western Australia
    Posts
    3,032
    Ok, there was a bug in v1.5 that has the symptoms you describe, but it only effected UK TiVo's.

    So, back to your original problem...you say it's not starting TWP. Did you install TWP yourself? or do you mean TiVoWeb that comes standard on the image.

    Also have you edited rc.sysinit.author on a PC? this will add dos characters to the file stopping it from executing.

    Peter.
    Please search this forum and our Website for your TiVo questions before starting a new thread. Thanks!

  5. #5
    Join Date
    May 2005
    Posts
    35
    Thanks for your reply.

    Yes twp, version 1.3.1.
    As i said it starts if i run it manually i.e. telnet and /var/hack/TivoWebPlus/tivoweb

    I originally edited rc.sysinit.author on a pc but read about the errors that could occur so created a new file on the tivo via joe and still doesnt work ?

  6. #6
    Join Date
    May 2004
    Location
    Wellington, NZ
    Posts
    477
    After rebooting the TiVo you should be able to check the /var/log/tivoweb.log file to see if the system as even tried to start the daemon. You may also wish have a look at the output of "cat -e rc.sysinit.author" to see if there are any odd characters in there.

    It could also be the case that something is being started in rc.sysinit.author before the call to tivoweb that is not being correctly placed in the background (with a trailing &)... hence it will not continue with the script until that process has completed (which it may never do).

  7. #7
    Join Date
    May 2005
    Posts
    35
    Thanks for your help guys,
    Here is the output of rc.sysinit.author using cat -e rc.sysinit.author.

    Ok should it have the $ signs ?


    #### START HACKS ####$
    $
    export MY_SERVER=10.0.0.1$
    export NFS_SERVER=$MY_SERVER$
    export SMB_SERVER=$MY_SERVER$
    #export TIME_SERVER=$MY_SERVER$
    $
    # Use extra libs (termcap, etc)$
    export LD_LIBRARY_PATH=/hack/lib$
    $
    #### Mount Network Shares #######$
    $
    # mount NFS shares (if you have them) Change the NFS_SERVER variable above to the ip of box with share$
    #insmod -f /lib/modules/nfs.o$
    #mount -t nfs -o rsize=8192,wsize=8192 ${NFS_SERVER}:/home/tivo /hack/nfs$
    $
    # Mount shares on your windows boxen.$
    # This doesn't work too well.$
    # insmod -f /lib/modules/smbfs.o$
    # smbmount //${SMB_SERVER}/SHARE /hack/smb -s putrename -c tivo -I x.x.x.x -U user -D WORKGROUP -P password$
    $
    #### Start Programs ######$
    $
    #CCXSTREAM - stream to XBOX$
    #google for ccxstream or search forums at xboxmediacenter.de$
    #ccxstream &$
    $
    #CRON # Edit /hack/etc/crontab $
    cron &$
    $
    #Start FTP daemon$
    #this is ADH's (from Deal Database) version that saves you from chmod +x$
    tivoftpd &$
    $
    #Start TiVoWeb$
    #/hack/tivoweb-tcl/tivoweb &$
    $
    #Start TivoWebPlus$
    /var/hack/TivoWebPlus/tivoweb &$
    $
    #Vserver - Stream ty files on port 8074 see tivo-mplayer.sf.net$
    #vserver > /dev/null 2>&1 &$
    $
    #EndPad$
    #If you want to edit the start and end, do so in /hack/bin/runendpad.sh$
    #/hack/bin/endpadplus.tcl 5 15 -auto$
    $
    #Start EndPad 1.5.1$
    /var/hack/bin/endpad.tcl -s 2 -e 10 -auto &$
    $
    ##### Various Other Hacks #######$
    $
    # Tweak HDD settings$
    # Don't worry if you don't have a two drive TiVo. It will work for 1 drive setups too.$
    # make certain runideturbo=false is in boot params, or rename$
    # the file /lib/modules/ideturbo.o to something else so it doesn't load.$
    hdparm -c1 -m8 -M1 -S0 /dev/hda /dev/hdb$
    hdparm -m16 /dev/hda /dev/hdb$
    $
    # Copy Module$
    # copies anything written to /var/packages to /tmp $
    # very useful for capturing tivo slices.$
    #insmod -f /lib/modules/copy.o$
    $
    # Emu Proxy$
    # A tool for cleaning up the HTTP output by the Tivo in order to pass through$
    # transparent proxies, etc.$
    # Works in conjunction with a small hack to the emulator to accept the header$
    # "TivoURLBase" which is the base url to give back to the Tivo when specifying$
    # data paths.$
    # Runs by default and is dependent on the$
    # 127::127.0.0.1:8000:::$
    # entry in tclient.conf$
    # IF YOU COMMENT THIS OUT SO IT DOESN'T RUN, YOU MUST EDIT THE "127" entry $
    # in /etc/tclient.conf to reflect the IP and port of the emulator you are using$
    # There is a backup of the original here: /etc/tclient.conf-oztivo$
    # Usage: %s [-d] [-h] [-l localport] [-L listenAddr] [-s serverip]$
    # [-p serverport]$
    emuProxy2 -s 131.244.9.101 &$
    $
    # Report IP - Handy for those not using DHCP-DNS functionality$
    # set dhcp hostname in /etc/dhclient.conf$
    # See http://www.isc.org/ for more info on DHCP and BIND$
    #report_ipaddress &$
    $
    # Trickey by Kevin Lentin provides a way to force tivo to $
    # run commands by assign remote key sequences. Very Cool!$
    # check out /hack/bin/trickey.README$
    trickey &[TiVo [p0] /etc/rc.d]#

  8. #8
    Join Date
    May 2004
    Location
    Wellington, NZ
    Posts
    477
    Quote Originally Posted by BenD View Post
    Thanks for your help guys,
    Here is the output of rc.sysinit.author using cat -e rc.sysinit.author.
    That file looks okay to me... might be nice to know what is in the /var/log/tivoweb.log file as this may contain the reason why TWP is not starting on bootup.

  9. #9
    Join Date
    Apr 2004
    Location
    Perth, Western Australia
    Posts
    3,032
    The $ signs are normal when you use the cat command.

    Apart from what Thomson has suggested, can you try "ls -l /etc/rc.d" and show the output.

    Also check the last line of rc.sysinit to make sure it has the following call to rc.sysinit.author

    [ ! -f /etc/rc.d/rc.sysinit.author ] || /etc/rc.d/rc.sysinit.author

    Peter
    Please search this forum and our Website for your TiVo questions before starting a new thread. Thanks!

  10. #10
    Join Date
    May 2005
    Posts
    35
    Output of /etc/rc.d directory

    [TiVo [p0] /etc/rc.d]# ls -l
    total 55
    -rw-r--r-- 1 0 0 3187 Oct 23 12:47 DEADJOE
    -rwxrwxr-x 1 0 0 1776 Feb 28 2002 finishInstall.tcl
    -r-xr-xr-x 1 0 0 4165 Dec 23 2004 rc.arch
    -rwxr-xr-x 1 0 0 3739 May 24 2005 rc.arch.original
    -rwxr-xr-x 1 0 0 185 Dec 23 2004 rc.net
    -rwxrwxr-x 1 0 0 187 Jan 26 2005 rc.net.airnet
    -rwxr-xr-x 1 0 0 267 Jan 26 2005 rc.net.airnet.static
    -rwxrwxr-x 1 0 0 188 Jan 26 2005 rc.net.cachecard
    -rwxr-xr-x 1 0 0 188 Jan 26 2005 rc.net.cachecard.static
    -rwxrwxr-x 1 0 0 200 Jan 7 2004 rc.net.tivonet
    -rwxrwxr-x 1 0 0 196 Jan 26 2005 rc.net.turbonet
    -rwxr-xr-x 1 0 0 246 Jan 26 2005 rc.net.turbonet.static
    -rwxrwxr-x 1 0 0 96 Apr 18 2005 rc.ppp
    -rwxr-xr-x 1 0 0 23677 Nov 17 2005 rc.sysinit
    -rwxr-xr-x 1 0 0 3064 Sep 27 19:38 rc.sysinit.author
    -rwxr-xr-x 1 0 0 3056 Apr 14 2005 rc.sysinit.noservices


    [TiVo [p0] /var/log]# cat -e tivoweb.log
    TivoWebPlus - v1.3.1 (1.3.1 (oztivo-061029))$
    The program comes with ABSOLUTELY NO WARRANTY.$
    This program is licensed under the GPL.$
    See the 'docs/copyright' and 'docs/index.html' files$
    for copyright and credit information.$
    PoolSize=2916352$
    child process exited abnormally$
    while executing$
    "exec ifconfig | grep "inet addr" | grep -v "127.0.0.1""$
    (file "/hack/TivoWebPlus/httpd-tt.tcl" line 990)$

Similar Threads

  1. Movie downloads available starting next week on TiVoHD.
    By petestrash in forum Australian TiVoHD
    Replies: 0
    Last Post: 25-11-2008, 06:32 PM
  2. starting recording early and late finish
    By donm in forum Question and Answer Forum
    Replies: 27
    Last Post: 22-09-2008, 04:08 PM
  3. TurboNet card not starting up
    By SteveCourt in forum Question and Answer Forum
    Replies: 6
    Last Post: 01-07-2008, 07:23 AM
  4. TIVOWebPlus not starting
    By jamesljm in forum Question and Answer Forum
    Replies: 23
    Last Post: 23-02-2008, 06:47 PM
  5. Replies: 1
    Last Post: 01-08-2005, 02:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •