View Full Version : TiVo time problem

26-01-2006, 04:02 PM
I wiped everything and ran GS again to fix another problem. Now the time on the TiVo and all the times in the EPG data are wrong. I get the following when typing fixtivotime in HT:

[TiVo [p0] ~]# fixtivotime
Our postcode is 02115. No matching timezone for postcode 02115
Usage: /tvbin/settime [YYYYMMDDhhmm[ss]] [-rtc]
Time set to: Thu Jan 26 17:58:24 2006
Have a nice day.

So from that I can see the TiVo should think it's the correct time (was correct at the time) but it says 9:58am when it's really 5:58pm. I don't have a linux box but I checked and the Auckland file exists in /var/hack/zoneinfo/pacific/.

I tried "chmod 777 /var/hack/zoneinfo/Pacific/Auckland" and got no such file.

26-01-2006, 04:14 PM
cd to /etc
type cp postcodezones postcodezone.bak


joe postcodezones

you need to add the 02115 postcode to the postcodezones file.. ie:

# A list of TiVo postcodes and the timezones that they represent
# Two columns, separated by one tab only.
02116 Pacific/Auckland
02115 Pacific/Auckland
0080 Australia/Darwin
02000 Australia/Sydney
02600 Australia/Sydney
03000 Australia/Melbourne
04000 Australia/Brisbane
05000 Australia/Adelaide
06000 Australia/Perth
07000 Australia/Hobart

Once added, save the file and try running fixtivotime.

26-01-2006, 04:23 PM
fixtivotime works now but the on screen time was still 5 hours out. I ran timezoneadj30.tcl and selected 7. I rebooted a couple of times and now it's correct. Thanks Zollymonsta for your help again. :D Now to do all my season passes again and get the logos loaded....

27-01-2006, 09:09 PM
No worries.. Glad to be able to help. :)