View Full Version : cant get past connecting

22-04-2004, 08:35 PM
Hello all
The tivo arrived today its a 112
I had previously installed ver 3.0 image to my hard drive{maxtor 40 gig]
..after fitting I booted tivo up,it boots first into maintenance screen then goes into guided setup and thats as far as I can get without letting it dialup
..I have a null modem cable setup which I connected via hyperterm and connected ok then tried to install the slice I had on my pc using this howto
.................................................. .................................
ftp'd them to tivo /var/hack/guide
- then loaded the slices
> cd /var/hack/guide;
> tivosh /var/hack/bin/dbload30.tcl output.PayTV.Aust.slice
> tivosh /var/hack/bin/dbload30.tcl output.Melb.FTA.slice
> cd /hack/bin
> tivosh fixup30.tcl
> tivosh force_index30.tcl
> touch /var/timestamp
.................................................. ..........................
I ftp'd to the tivo and copied the slice to it ok
but when I tried the rest of the commands it said "no such dir" or something like that.

This is a copy of my hyperterm log...
Loading boot image from partition 3
Loaded successfully ...
Entry point at 0x80010000 ...
IDEprom: jump to boot_entry (0x80010000)
Boot jump to 0x80010000, params=root=/dev/hda4 TV_STD=PAL GS=1
¬*½þ¬*½þ¬*½þ¬*½þ¬*½þ¬*½þ¬*½þ *½þ¬*½þ¬*½þbash: no job control in this shell
[TiVo [S3] ~]# [TiVo [S3] /var/hack/guide]# couldn't read file "var/hack/bin/dbl
oad30.tcl": no such file or directory
[TiVo [S3] /var/hack/guide]# couldn't read file "/var/bin/dbload30.tcl": no such
file or directory
[TiVo [S3] /var/hack/guide]#
any help about what to try next?
Is there a way of bypassing the first forced dialin?
If not I will try doing a dialin via my isp but dont know how to setup
the phone number etc

thanks splitpin

22-04-2004, 11:16 PM
Unless you have a very good reason, i would not try to bypass the guided setup as it does a number of semi-critical things to get the box going. Once they are achieved you can then hack to your hearts content.

In particular you wil need to setup a STB and channel line up.

Go to the OZTIVO TWIKIs - there are a number of documents there about setting up a TIVO to dial an ISP and which ones do and do not work


Hello Moto
28-05-2004, 10:43 AM
Hi Splitpin,

My TiVo has the same problem - I cant get passed the compulsory dial-up.
How did you get around this problem. I have looked around and can't seem to identify a way around it. (Perhaps this is my newbiesness too).

Thanks for anything you might tell me....(perhaps if this is a common issue, we could put up a stickynote for other newbies??) :confused:

28-05-2004, 12:24 PM
Have you worked your way exactly through the guided set up how to?

Have you also looked through the appropriate how to for whatever way you are connecting to the Internet?

Why does it want to dial up? Is that the method you are intending to use to get guide data?

What do you mean you can't get past .... What exactly is the TiVo doing/saying.

We need more information to help you out.


30-05-2004, 08:30 AM
I guess the only confusion I think people encounter is that it's called a "Daily Call" so people automatically think they need to "dial up"

Since you have a serial cable, and I presume you'd be connected to the internet, you might want to be looking at the Networking HowTOs (http://minnie.tuhs.org/twiki/bin/view/Howtonetwork/NetworkingHowto) on minnie.

Hello Moto
30-05-2004, 12:04 PM
Hi All,

After staying up all night Friday I cracked it and I am very pleased with myself.
I misread the instructions and set my DialPrefix to ',#211' when it should have been ',#401'. This cost me many huors of constant reboots, testing cbales, serial ports etc etc.

Anyway, its up and running since Saturday 6am (EST) and all is fine EXCEPT;
1. Cant get IR codes to control Optus cable box
2. Cant get 30 second skip to work

Any quick pointers on these two issues?
Thanks again. :p

30-05-2004, 08:22 PM
30 Second Skip can be activated by going to the "Now Playing" screen, playing a recorded program, and then pressing the buttons on your remote in this order:

3 0

That's the number 3, then the number 0 (zero). Your TiVo will then "ding" 3 times at you and you will be able to use your "skip to end" button as a 30 second skip. If you want to enable the hacks, do a quick search for it using the "search" button on these great forums :)

02-06-2004, 02:48 PM
Assuming you mean Optus Cable then select the Jerrold box from the Cable provider list - you then use IR code set up high in the list something like 73 or 90 something if i remember from the last time i did it.

Most of the Optus STBs are the Jerrold unit - however some are a different make.

THe Jerrold units are Mono output on the RCA plug at the back - the other units are stereo

If you want Permanent 30 sec skips then look in the TVBIN directory and you will see the different hacked versions of the TIVOAPP - one in there is named 30secandback doors (or something similar) Rename/Move that to TIVOAPP (after renaming the original) then do a reboot and you will have both - however many people report that your TIVO will lock up after 7 - 14 days using this hacked TIVOAPP