View Full Version : FTP Frustration

07-08-2005, 06:59 AM
Hi Folks,

Have been chasing my tail a little bit and could do with some assistance. I'm trying to setup to transfer files to my pc and burn to dvd.

I have been happily using my tivo (serial 1 phillips) for months and have only now required FTP.

Presuming this would be setup already as part of the image setup (i followed the oztivo help guide etc) i tried to connect with my ftp client - no joy. Have tried with several clients and none will connect. I therefore presumed that the ftp server is not setup or not started...

Telnet'd to Tivo and checked the rc.sysinit file to ensure tivoftpd is started at boot - it is. BUT i cannot actually find the tivoftpd file anywhere - have checked in every bin file....

I'm now trying to find out if tivoftpd is running at all (and i have just missed where its filed) - can someone help with this? I scanned through my messages log and found:

Aug 7 08:05:54 (none) tivoftpd: error initializing FTP listener; error binding address; Address already in use

trying to go back to scratch i want to first ensure tivoftpd is on the machine and running - help appreciated as my **** is sore from sitting here trying to figure this one out :confused:


07-08-2005, 11:55 PM
tivoftpd is on by default on the last few images. From the message you received when you tried to start it manually it would seem that it is already running.

If you type 'ps ax' in a telnet session and look though the list of processes running you should see something like
xxx ? SW 0:00 (tivoftpd)

But in actual fact you are barking up the wrong tree anyway. tivoftp is only used for transfering system files to and from your TiVo.

Which oztivo guide did you read? I will need to correct the references to tivoftp as it's not used for extraction.

for the correct proceedures see the Videoextract (http://minnie.tuhs.org/twiki/bin/view/Videoextract/WebHome) twiki.

You will see there are a few different ways of achieving the same result.