View Full Version : Can't image Hard Disk - help please...!!

31-05-2005, 08:07 AM
Hi all

I'm trying to put the OzTivo image on my hard disk.
I've created the ISO ok and I can boot the ISO CD in my computer.

It comes up with the boot: prompt and I hit enter - then just a blank screen...!!!

I've tried different computers, tried different CD-ROM drives, even imaging a different hard disk.

I've also tried booting with the mfstools boot cd - once again I get the boot: prompt, but when hitting enter, it gives me a "crc error".

Any help would be greatly appreciated.

31-05-2005, 11:06 AM

Strange, the ISO image should work in most PCs, particularly if the hardware isn't too cutting edge.

I'd suggest checking the MD5SUM of the ISO image.

If that looks OK, which image version (eg. 20050524) did you use?

Cheers, Dave.

31-05-2005, 11:17 AM

The md5 file on the ISO CD image I created is:

6205f3fe62df37935fd09f517ea6f24a ozTiVo_HDRX12_3.0-20050524.mfs

Any further help would be great as I'm lost....!!



31-05-2005, 11:51 AM
Hi Matt,

The file you've downloaded should have an "iso" extension, not "mfs". Did you get that number by running a md5sum check on the file? This page provides some good information on how it's done:


The result should be the same as in this file:


Cheers, Dave.

31-05-2005, 07:22 PM
Hi Dave

I probably didn't explain myself too well.

It was an .ISO file that I downloaded. The CD booted up ok - but hung after the boot: prompt.

I ran the checksum and that came up with the right numbers as supplied by you. So I can only assume that the ISO is fine.

That only then leaves me with the computers I've tried to image from. They are just an old Pentium 2 and pentium 3 - nothing special.

Any further ideas???

Thanks for your help.


Darren King
31-05-2005, 09:00 PM
Hi Legend

Had further thoughts to it from this mornings email but will take it up here on the forums as you will get more of a wider audience than just "one on one".

First of all, I don't see older computers being a problem for burning the image. If you have used something pretty standard like Nero for example to burn the ISO then this is all you need to actually create the CD.

What I didn't suggest this morning but throughout the day thought of is the following:

1. PC you are attempting to image from has had it's usual hard disk disconnected

2. Your TiVo hard disk has been set to "master" and not left as CS (cable select)

3. You are not putting the TiVo hard disk as primary master (linux parlay HDA) but preferrably secondary master (HDC) device

4. The PC has a BIOS that will allow a CDROM device to be bootable

Any of those help?


31-05-2005, 09:06 PM
Hi Matt,

That really only leaves the hardware. You might have to try (yet) another PC.

The bootable CD image is based on Knoppix 3.3 (dated November 2003) - as per the splash screen that appears with the boot prompt.

Also it's safe to do a quick test by booting a PC off the CD without disconnecting the PC's normal HDD - as long as you don't proceed to restore the TiVo image. Just press <CTRL><ALT><DELETE> if you get to the install menu and it should shut down again. That way you can tell if it's worthwhile opening the case etc.

Sorry, not much else I can offer.

Cheers, Dave.

01-06-2005, 07:54 AM
Here is a list of things I've tried....

1. Hard Disk as Secondary Master and CDROM as Primary Master (as detected by the BIOS during boot up).

2. Setting the computer BIOS to boot off the CD (the Knoppix splash screen appears - but then hangs after the boot: prompt).

3. Normal computer hard disk is disconnected.

4. CD burnt with Nero.

No luck with the above.

I will be trying a different PC today to see if I have any further luck.

Thanks for everyone's help...!!

01-06-2005, 12:27 PM
After getting advice from a friend - I tried Alcohol 120 to burn the CD - and no problems.

The next issue I'm facing is an error message :


Please append a correct "root=" boot option
Kernal panic VFS: unable to mount root fs on 03:01


Any more advice guys????

01-06-2005, 02:22 PM
Hi Matt,

You might be able to get around this by typing something like this at the boot prompt:

boot noscsi nodma

If this doesn't work there are some other cheatcodes (as they're called) you could try. If you hit F2 at the boot prompt you'll see them.


Cheers, Dave.

01-06-2005, 08:40 PM
Hi Matt,

Make that

or perhaps:

nodma noscsi
at the boot prompt.

Sorry about this afternoon's post. I was flying blind.

"nodma" is actually a label for a more complicated boot command. The file isolinux.cfg on the CD shows what switches the full command is using:

DEFAULT oztivo
DISPLAY boot.msg
F1 boot.msg
F2 f2

LABEL oztivo
KERNEL bzImage
APPEND 2 ramdisk_size=100000 init=/etc/init lang=us apm=power-off hda=bswap hdb=bswap hdc=bswap hdd=bswap hde=bswap hdf=bswap hdg=bswap hdh=bswap vga=788 initrd=miniroot.gz nomce dma BOOT_IMAGE=knoppix

LABEL nobswap
KERNEL bzImage
APPEND 2 ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=788 initrd=miniroot.gz nomce dma BOOT_IMAGE=knoppix

LABEL nodma
KERNEL bzImage
APPEND 2 ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=788 initrd=miniroot.gz nomce ide=nodma BOOT_IMAGE=knoppixSo to play with these values you'll need to use a full command starting like this:

bzImage 2 ramdisk_size=...
HTH more than earlier.

Cheers, Dave.