View Full Version : Trouble Mounting the TiVo drive on my PC

08-02-2005, 12:14 AM
I am trying to mount the TiVo drive on my PC with no success

My freshly prepared (from OZ image) 80 GB TiVo disk is on the primary
master and I boot with the OZ CD on the primary slave.
I am trying to mount the TiVo disk by typing

mount /dev/hda /mnt/tivo

But I get the "filesystem must be specified" error.
When I try the following command which I saw in one of the mailing
list threads

mount /dev/hda4 /mnt/tivo

I get one good line:
/dev/hda4 Sucesss
But then the second line is the same error message as before.

I do not understand what these numbers after the hdx are. Something
to do with the partition probably.
During the startup, I do get a message that no partition table is found
for the hard disk.

I tried swapping the master and secondary (so that the CD will be
hda and the tivo hdc - I understood from one of the postings that this
may affect byte swapping??), but same results.

I had no trouble mounting a dos floppy disk.




14-02-2005, 04:33 PM
I remember this from a previous mailing list thread. The drive is byte-swapped. There are utils to read the drive, but it cannot be done via a standard program like Partition Magic, or from dos, or from your standard linux installation.

If I make the assumption that you are installing the image onto a new clean hard disk drive, you do NOT need to mount it.

All you need to do is follow the instructions per the boot CD.

Extra hints:

/dev/hda - Primary Master Hard Disk
/dev/hdb - Primary Slave Hard Disk
/dev/hdc - Secondary Master Hard Disk
/dev/hdd - Secondary Slave Hard Disk

The numbers that follow are the partitions. ie /dev/hda1 would be Primary Master Hard Disk drive, First Primary Partition. /dev/hda2 - Second primary partition. hda3 and hda4 are 3rd and 4th primary partitions. hda5 is an extended partition. hda6 is a logical partition based in the extended partition.

If you aren't following the concept. Imagine a Train. The train exists of 4 (hda1, hda2, hda3, hda4) primary engines pulling the load. The next car along is a container (hda5). The container can be full of logs (hda6), as well as coal (hda7). It's just one BIG container :)

Hope I've answered your question in a roundabout way :P

15-02-2005, 02:52 AM
Following the lead from Tenty (Thanks!), I found out that the
problem is the byte swapping of the TiVo system.
The only way I could mount the TiVo disk (actually specific
partitions, as is alluded in old threads) was using Dylan's
boot disk, which assumes the byte swapping (the TiVo general
FAQ lists the partition table and which partitions can be mounted
on a PC with Linux).
However the floppy boot disk is naturally very limited, and
the question is whether there is a Linux distribution for Intel machines
that supports byte swapped disks.



17-02-2005, 08:37 PM
Hi Gideon,

When you boot from the CD, instead of just pressing Enter at the boot prompt, try this instead:

vmlnodma hda=bswapCheers, Dave.