View Full Version : OzTiVo Hard-disk / Airnet install problems

22-10-2004, 07:09 PM

I have put the OzTivo image file onto a 120GB hard disk which works fine when I install into the Tivo. I am now trying to install a TiVo Airnet card into the TiVo. I boot a PC with the OzTiVo boot disk and the drive connected but I cannot get the drive to mount at all. The bootup information recognises the drive but none of the partitions. Where am I going wrong? All I want to do is install the NIC_Install drivers but without mounting the drive I'm stuck.
Any help would be gratfully recieved.



22-10-2004, 11:03 PM
Hi Richard,

This might work for you:


Cheers, Dave.

23-10-2004, 01:44 PM
You now need to take the HD out of the Tivo and place back into your PC. Now burn another ISO CD with the nic drivers. Instructions and file link is on this page http://www.silicondust.com/turbonet/install_software.html

you will then be able to set up fixed or DHCP ip for the Tivo. Then place it back in your tivo and start it up

02-11-2004, 09:28 PM
Thanks guys - sorry for the delay in returning to you!

Thats progressed me a little.

Now I have another problem. When I do the:

"nic_install airnet" bit

I get so far then it Errors.....

Detecting TiVo partitions...

Active Kernel partition = /dev/hdb3
Inactive Kernel partition = /dev/hdb6
Active root partition = /dev/hdb4
Inactive root partition = /dev/hdb7
Var Partition = /dev/hdc9

Determining software version
Philips SA running 3.0-01-1-00

Scanning for initrd...
Initrd not found

Mounting partitions
Root successfully mounted

Error - Unable to mount partition "/dev/hdb9" (22)

Anyone got any ideas on how I can progress this further?

Many thanks


02-11-2004, 11:50 PM
Hi Richard,

Having done a search on the Silicondust forums ...


... it might be that your disk is locked.

Does your PC detect the drive as the correct capacity while it's booting?

If it is detecting as about 9MB then it is locked and this might help:



Cheers, Dave.

07-11-2004, 08:26 PM
Ok. The Bios seems to be reporting the drive details correctly. The drive is a 120GB Samsung which previously ran the UK TiVo package (upgraded). I have tried two different PC's using hdcb, hdc & hdd! Still, the nic_install software refuses to recognise initrd or mount var partion hdx9!!

Any suggestions would be appreciated as this is driving me round the twist. Can samsung drives be locked / unlocked?



12-11-2004, 08:12 PM
Hi All

Looks like I fixed it for now. I used the nic_install software on the TiVo using the serial port on the TiVo. I still have no idea why the nic_install procedure would not work on the Linux mounted PC.

My only problem now is that the TiVo is reporting 10hrs best quality reporting for a 120GB drive!!! How do I correct this? Everything else works great!