View Full Version : Error S03 and No Guide Data

04-03-2018, 11:38 PM
Hi all

I have 2 TiVos - both modded by Darren a few months back (thanks Darren!) and have been working well since the move to OzTiVo.
Until now.

On Saturday night I noticed one of the TiVos had almost no guide data left and the last attempt to connect had failed.
I ran "Connect to the TiVo Service now" and it returned "Error S03" during the Final (Loading) Phase.
I tried again and it retured "Error S03" during the First (Preparation?) Phase.
I ran it a few more times and each time Error S03 was thrown up - it seemed to oscillate between the first and last phases.

On Sunday I spent some time mucking around with it and I've now managed to clear the S03 error by:-
1. Wiping all my season passes
2. Deleting old groups of programs (from before the modding/move to OzTivo) where there was also a new group for the same program since the upgrade. (Something I read somewhere suggested Error S03 was caused by indexing, so I figured having duplicated group names might be part of the problem)
3. Doing a Clear Program Info & To Do List
4. Re-starting the TiVo

However, although the S03 error is cleared, I still can't get any Guide Data.
Each attempt to "Connect to the TiVo Service now" is successful (and seems to run quite quickly compared to before all this) but the EPG is not updated.
And when I look under System Information -> Program Information To, it shows "None Available".
I've left it for several hours, in the hope that it was just taking a long time to load the EPG, but still nothing.

I'm tempted to try to run a Guided Setup, but I've seen a warning from Darren somewhere that I may lose my MAK if I run Guided Setup.
So before I try Guided Setup, I thought I'd post here and see if anyone has been through this before, or has any other suggestions...?

Thanks in advance

PS - Don't know if it makes any difference, but this particular TiVo has a WD Expander Drive...

05-03-2018, 04:25 PM
A guided setup shouldn't clear your MAK. A Clear & delete everything will. You could try making a copy of your drive and practicing on the copy to see what fixes your problem.

03-02-2019, 10:10 PM
Hi all

I recently had a message from someone asking if I ever resolved my problem and I realised I hadn't uploaded the follow up message I'd written, documenting what I did to fix the problem.

So, in case anyone else encounters an S03 error with similar circumstances to mine, here's what transpired...


From what I gleaned through Google an S03 error is an error with the Hard Drive and may indicate a failing drive.
This Tivo is 9 years old and still running the original drive, so I was concerned its time might be up.
However, an S03 can also indicate an error on the drive - which can be corrected.

From what I read there are a couple of things to try...

The first course of action is to clear all thumbs and suggestions, do another restart and connect to the TiVo service again.
This seemed to partly fix my problem... When I did this the LOADING phase of the Connect to TiVo Service took a lot longer to load (back to the usual length of time) and the guide then had data - but the first 24-36 hours was rubbish... the one program on each channel stretching out over the next couple of days. After that the guide seemed good.
I connected a couple more times, but the guide was still rubbish for the next day or so.
I left it for 1/2 a day and connected to the TiVo service again, thinking I might just be able to let time catch up to the guide.
However, this just pushed the point where the guide was correct further out into the future.

The next thing to try is "kickstart code 57", which runs a checkdisk process over the hard drive and attempts to correct errors it finds.
You restart the Tivo and while it is restarting you hold down the yellow pause button until the red and yellow lights on the front panel come on (it may take a while).
When these lights come on, release the pause button and press 5 and then 7 on the numeric buttons.
You'll get the Tivo is restarting screen, but after a while you get a scary green screen telling you that a serious problem has been found and the Tivo is now going to try to fix itself and that it may take 3 hours.
Mine didn't take anywhere near this long - probably only 1/2 an hour (maybe because it's the small 180GB drive in this model TiVo).
The Tivo gave no message or indication that anything was wrong or fixed (that I saw) - it was just running again when I came back to it.
I tried connecting to the TiVo service again.
This time the point where the guide data looked okay didn't move... It was still rubbish for the next day and a bit, but beyond that it was okay.
I suspected the problem was now fixed, but rather than playing with it more to correct the guide I just unplugged the ethernet cable for the next day and a half and let time catch up to the good data.
Since then the guide has been good and is updating okay.

One side effect though - for shows that were recorded prior to all this, the "More Options" option (when you select a program from the Now Playing List) is either missing (replaced by "Don't do anything") or, if it does exist, no longer has the "Get a Season Pass" option when you select it.
Options for shows that have been recorded SINCE the fix are all okay.

It's now been close to 12 months since I had this problem, and haven't had a recurrence.