View Full Version : EPG update error in "Connecting" phase ((Failed while negotiating)

20-01-2018, 03:08 PM
I had my TiVo 3 modified in early January and initially the EPG updated. But the last successful update was the 13/1/2018. Since that time when trying to update the EPG I get an error message at the "Connecting" stage I get "(Failed while negotiating)" I then get the an error when I press the remotes "Select" button indicating error N17.

My Software is 11.3b and

the Tivo Service number is 663+0001+9027-10C0

I have tried to go through the guided setup routine and now the TiVo Box is in a loop restarting the guided setup when it tries to upload the EPG data. I cannot seem to get out of this loop even after I turn off the TiVo and then power it up again.

Some things I notice are the "Setting Dial Config 140"
It does seem that the TiVO Box initially connects to the "OzTivo Mothership" on the initial part of the guided setup and then scans for the Digital TV channels in our area of which there are 41. It is then that it goes through the process of seeking to down load the EPG data, firstly going through the "Preparing" phase, which takes a few minutes, then moving the "Connecting" phase where I get the message.

Any ideas on who to resolve this issue would be appreciated.

Darren King
20-01-2018, 05:13 PM
Given your software is 11.3b8 I'd be inclined to just wipe the hard disk and load it with a fresh copy of 11.3b10

20-01-2018, 06:04 PM
Given your software is 11.3b8 I'd be inclined to just wipe the hard disk and load it with a fresh copy of 11.3b10

It looks from mothership logs like Kandels' TiVo made some progress with Guided Setup about 10 minutes after he posted.
If the TiVo is still stuck (in a guided setup loop) and it's running 11.3b8 and you are happy to lose recordings, season passes, etc currently on it, and you only have a single hard drive in the TiVo then restoring a 11.3b10 image onto your hard drive is probably the quickest way to get it going again, and it will also mean you get the benefits of 11.3b10 rather than being stuck on 11.3b8.

20-01-2018, 09:33 PM
How do I go about loading 11.3b10 on the hard disk?

Darren King
20-01-2018, 10:12 PM
I can give you the full procedure and the pre-patched 11.3b10 image and the software tool to get it loaded if you send me an email.

22-01-2018, 08:27 PM
I am a little concerned about reimaging my Tivo HD. I started the process last night and downloaded the attached text Mfsinfo.txt file from WinMfs (See Below) which indicates that my version is Software: 11.3b10.2017.10.11-1506-01-2-Z-663 this is the latest version as I understand it and I think it was assumed that my problem was due to the Software: 11.3b8 revision. I just do not want to lose all my previous recordings. At the moment I am downloading them using Tivo Desktop

Mfsinfo (Drive 0)

Boot Page
Boot Page: root=/dev/hda4 dsscon=true console=1,115200 hacks=telnet,ssh,,serial upgradesoftware=false
Active Boot Partition: 3 Active Root Partition: 4
Backup Boot Partition: 6 Backup Root Partition: 7

MFS Super Header
state=0 magic=ebbafeed
devlist=/dev/hda10 /dev/hda11 /dev/hda12 /dev/hda13 /dev/hda14
zonemap_ptr=1121 total_secs=3905159168

Zone Maps
Z0: type=0
map_start=1121 map_size=1 backup_map_start=589822
next_map_start=263266 next_map_size=10 next_backup_map_start=589812
zone_first=1122 zone_last=263265 zone_size=262144 min(chunk)=262144
free=262144 checksum=e5857c8c logstamp=45049449 num_bitmap=1
Z1: type=2
map_start=263266 map_size=10 backup_map_start=589812
next_map_start=263276 next_map_size=34 next_backup_map_start=589778
zone_first=589824 zone_last=278851583 zone_size=278261760 min(chunk)=20480
free=0 checksum=7bb6aa6b logstamp=45049449 num_bitmap=15
Z2: type=1
map_start=263276 map_size=34 backup_map_start=589778
next_map_start=278855680 next_map_size=1 next_backup_map_start=279445503
zone_first=263310 zone_last=589773 zone_size=326464 min(chunk)=8
free=254608 checksum=60ceec1e logstamp=45050130 num_bitmap=17
Z3: type=0
map_start=278855680 map_size=1 backup_map_start=279445503
next_map_start=279117825 next_map_size=18 next_backup_map_start=279445485
zone_first=278855681 zone_last=279117824 zone_size=262144 min(chunk)=262144
free=262144 checksum=64be285a logstamp=45049449 num_bitmap=1
Z4: type=2
map_start=279117825 map_size=18 backup_map_start=279445485
next_map_start=279117843 next_map_size=34 next_backup_map_start=279445451
zone_first=279445504 zone_last=623263743 zone_size=343818240 min(chunk)=20480
free=0 checksum=a04bf89a logstamp=45049485 num_bitmap=16
Z5: type=1
map_start=279117843 map_size=34 backup_map_start=279445451
next_map_start=623272960 next_map_size=130 next_backup_map_start=623273090
zone_first=279117877 zone_last=279445444 zone_size=327568 min(chunk)=8
free=298384 checksum=3d8354cf logstamp=45050071 num_bitmap=17
Z6: type=2
map_start=623272960 map_size=130 backup_map_start=623273090
next_map_start=0 next_map_size=0 next_backup_map_start=-6148914691236517206
zone_first=623273984 zone_last=3905153023 zone_size=3281879040 min(chunk)=20480
free=100720640 checksum=3b6c0d24 logstamp=45049485 num_bitmap=19

Partition Maps
#: type name length base ( size )
1 Apple_partition_map Apple 63@1 ( 31.5K)
2 Image Bootstrap 1 1@343828384 ( 512.0 )
3 Image Kernel 1 16384@343828385 ( 8.0M)
4 Ext2 Root 1 524288@343844769 ( 256.0M)
5 Image Bootstrap 2 1@344369057 ( 512.0 )
6 Image Kernel 2 16384@344369058 ( 8.0M)
7 Ext2 Root 2 524288@344385442 ( 256.0M)
8 Swap Linux swap 262144@344909730 ( 128.0M)
9 Ext2 /var 524288@345171874 ( 256.0M)
10 MFS MFS application region 589824@345696162 ( 288.0M)
11 MFS MFS media region 278266638@346875810 ( 132.7G)
12 MFS MFS application region 2 589824@346285986 ( 288.0M)
13 MFS MFS media region 2 343828320@64 ( 164.0G)
14 MFS MFS media region 3 3281886720@625142448 ( 1.5T)

Total SA SD Hours: 2083 Total DTV SD Hours: 1818 3 % Free
Software: 11.3b10.2017.10.11-1506-01-2-Z-663 Tivo Model: TCD663320

What are your thoughts about other possible solutions?

22-01-2018, 11:27 PM
If you are running 11.3b10 and you don't want to lose your recordings, then I would try other things and leave re-imaging as a last resort if you can't break out of the guided setup loop.
Are you still stuck in a guided setup loop? If so, can you tell us what postcode are you putting in for guided setup, and where are you?
You might want to try guided setup again while you are waiting for suggestions for us, in case it comes good by itself after a while.

23-01-2018, 08:26 AM
I am in the guided setup and the postcode I am using is 5000 and I live in Adelaide

24-01-2018, 08:56 PM
Hi Kandels,

I'm having a very similar problem (haven't tried guided setup yet). One weird thing I found was that my Tivo has the wrong time. It appears to think it is in Sydney (although I am in New Zealand). Since you are in Adelaide I wonder if you've noticed whether the time is wrong on yours?

24-01-2018, 10:27 PM
I am in the guided setup and the postcode I am using is 5000 and I live in Adelaide

Not sure if it helps you, but I have run guided setup with post code 5000 on my test tivo, and it worked fine with no problems (and now thinks it is on SA time, half hour different to Melbourne wall clock time).
So it's not a systemic problem for anyone trying to use postcode 5000.

31-01-2018, 09:34 PM
I have tried a few thing using WinMFS using a share hard drive but I loose the TiVo Desktop functionally which I don't want to do. I was going to try to redo the OzTiVo HD install but have a problem with my PC loading Puppy Linux. I have an older PC loaded with Ubuntu can I run the OzTiVo installer using Ubuntu? If so how?