View Full Version : Daylight savings time change

27-09-2009, 03:34 PM
Hi All

daylight savings change not taken.

Done sever call home and reboots, tried force index - anyone else having issues or is it just not updated on the server?


27-09-2009, 05:38 PM
The problem is most probably in your TiVo not the server,
One of my TiVos has failed the daylight savings change (recently installed HDD - I forgot to update for dayligt savings) .
Use the process described here http://forums.oztivo.net/showthread.php?t=1638 it has worked perfectly for me before.

27-09-2009, 07:03 PM
I'm having the same problem ,on a recently installed HDD. Just ran the file as oer the link, but still an hour out. Any suggestions?

27-09-2009, 07:38 PM
I am reasonably sure I did do the "allow for Daylight savings" bit of the setup - then again I had to redo it a few times.

For now I have used settime to see if it fixes itself next call home and if it doesn't I am getting sound disappearing so I may have to get a new hard drive any way (hope it is the HDD and not the PSU going west)

Interesting I am not the only one.

27-09-2009, 07:42 PM
Where is the settime file in the image? what is the format?

27-09-2009, 07:57 PM
Well its clear that my problem is with the auckland daylight savings settings file. My daughters tivo has done daylight saving correctly, and the output of daughtels -la /var/hack/zoneinfo/Pacific/Auckland is 882 as intended, if I run the same file on mine I get 887 or something similar. When I run the script as per the link I can see lots of 'invalid port' errors as it streams through. Is the script pointing to the wrong place for the updated timezone file?

27-09-2009, 07:58 PM
When you followed the instructions in the link did you get the correct file details of #-rw-r--r-- 1 0 0 882 Sep 21 21:17 Auckland

Also you will need to run /bin/ntpdate -b -v and from this you should get the result:

[TiVo [p0] ~]# /bin/ntpdate -b -v
Our postcode is 02112. Found matching timezone Pacific/Auckland
Offset 46800 for timezone NZDT, daylight saving is 1
Connecting to time server
Setting the local time to Sun Sep 27 22:55:23 2009
gmtime gives 109/8/27 22:55:23 [0]
sending to clock 09/09/27 22:55:23 [0]

This should show daylight savings is 1 and will set the time.

27-09-2009, 08:05 PM
When you followed the instructions in the link did you get the correct file details of #-rw-r--r-- 1 0 0 882 Sep 21 21:17 Auckland

No, I get a result of 870, not 882

Running the code in the link I can see lots of error messages scrolling down the screen, then the Tivo reboots, time unchanged, tried it several times now, much to wife's annoyance!

27-09-2009, 08:06 PM
When I run the script as per the link I can see lots of 'invalid port' errors as it streams through. Is the script pointing to the wrong place for the updated timezone file?

I'm not sure what you mean by 'script' in the post.
What were your results from an ntpdate?

27-09-2009, 08:11 PM
Daylight saving = 0

Sorry, by script, I mean the lines of code.

27-09-2009, 08:21 PM
When entering the commands which is the first one to not give the expected result?
Also if you get a result of 870 you still have the old Auckland file not the new one.

28-09-2009, 06:42 AM
You could just manually replace the file. Download Auckland.zip from here
and replace the file as described in that thread.

28-09-2009, 03:39 PM
Fails to get the auckland zip file. Seems to log onto server ok, then comes up as invalid port.

28-09-2009, 03:56 PM
Can you download the file by entering its location in a PC web browser.

If unable to maybe you have a blocked port on your internet router?

28-09-2009, 04:01 PM
yep that worked fine, saved it to my PC. Don't know how to transfer it to my Tivo though!

28-09-2009, 04:40 PM
when I run wget at the Tivo bash prompt (using putty) I get:
Connecting to connected
loggin in as anonymous logged in!
CWD Install-done
Invalid port

giving up

Seems like it's close to working! Anyone help?

28-09-2009, 04:46 PM
To transfer the file to your TiVo from your PC you will need an FTP program on your PC (The one I use is FileZilla)

It does seem strange that you can't download the file directly to your TiVo using

If using an ftp program put the Auckland.zip file into /var/hack/zoneinfo/Pacific/ and run unzip Auckland.zip in that directory. It is best not to unzip the file on your PC before transferring it.

28-09-2009, 04:49 PM
I downloaded filezilla client earlier, but haven't a clue how eo use it! I've opened it up and can see files on my PC, but don't know how to make it see the tivo....

28-09-2009, 05:28 PM
To use FileZilla enter your TiVos IP address in the host box and then hit quickconnect. If all is correct you should see a bunch of commands run in the box below the host box and the left hand boxes should come up with your TiVos file structure.
From there you should be able to drag and drop the file from your PC into the correct directory in your TiVo.

28-09-2009, 05:39 PM
Sorted! Transfered file, unzipped, ran check and got 882 back, so all good! Thank you so much for you help!

28-09-2009, 05:44 PM
Good to hear.

29-09-2009, 06:56 AM
Followed the instructions as per a few posts ago, and ls -la /var/hack/zoneinfo/Pacific/Auckland now gives 882.

When I do /bin/ntpdate -b -v I get Our postcode is 02110. No matching timezone for postoce 02110.

Time still shows as an hour out. Any ideas?

regards, Sandy

29-09-2009, 08:46 AM
Message for TonyS... as I read this thread I got the impression that you copied and pasted the "script" as you referred to it in its entirety from the linked reference. If so note that the instructions are a sequence of linux terminal commands that should be cut and pasted into the telnet terminal one by one. The clue that alerted me was that you said you saw a series of error messages scrolling by and then the tivo rebooted.

I hope this comment might be useful for others reading this thread too.

29-09-2009, 09:16 AM
I must admit, initially I tried cut and paste, hence the string of errors. I then tried typing the instructions in line by line, and still had the 'invalid port' failure when attempting to download the zip file. Downloading it to my PC, then ftping it into Tivo worked fine. Would still like to know what the problem with the download is....

29-09-2009, 09:35 AM
Perhaps 02110 is not listed in the timezones file, previous advice has been:
You'll need to edit /etc/postcodezones and make sure the postcode number you used in guided setup is in the list. Just add it in, with a tab seperating the number and the Pacific/Auckland part and an Enter at the end of the line.

I think this would be done by:
cd /etc
joe postcodezones
add the line, hit cntrl+k then x to exit and save changes

Then it should work. I'm not at home so can't verify this.

29-09-2009, 05:56 PM
Thank you!! 02110 wasn't in postcodezones and adding it worked a treat!
regards, Sandy