View Full Version : Failed: Service unavailable

13-04-2009, 11:31 AM
For some reason, my S1 has failed to collect guide data since the 9th. I don't believe there has been any relevant changes here to connectivity or configuration, and connectivity to the Tivo seems fine. When I try to force a connection with the "phone" option on TivoWebPlus, it attempts to connect, but after a few minutes displays "Failed: Service unavailable". I have tried it quite a few times.

So my obvious question is - Is this just me or is there a wider issue?

On the assumption that it is a problem with me, what can I do to home in in the problem.


13-04-2009, 02:53 PM
When viewing the Last Attempt Status it says Succeeded..

I don't have any guide data and have followed http://www.oztivo.net/twiki/bin/view/Guidedata/WhyIsThereNoGuideData

- Made a manual daily call and checked it has completed with "grep 'Sweep done' /var/log/tvlog"
- I have compared my data with the on-line tvguide.. tvguide says there should be some
- Using the myslices finder i can see that i have data until 12/April and then no more..

- I have downloaded all the slice files for WA06000_* manually and loaded, still no luck..

I am looking after 2 tivos at different locations and both have the same issue, I am yet to confirm if another 2 known tivos have the same problem.

Not sure what to do next, any pointers would be great...

13-04-2009, 04:03 PM
syeoman, there was an issue with some WA data over the Easter weekend.

This has now been fixed.

Try forcing another call to the server.

SteveP, assuming you are in Australia, please follow what syeoman did and report back the results.

Could you both please add your location to your profile to make future support easier.


13-04-2009, 04:30 PM
Thanks Pete,

Made a manual daily call and data has successfully downloaded and is available.


13-04-2009, 08:17 PM
Should have stated my location - It's Melbourne.

My problem is that the call does not proceed.

I've got this in /var/log/kernel when I try the call which is probably significant. Lots of other stuff in other logs, but I'm not sure what is relevant to the issue.
Apr 13 19:55:53 (none) kernel: Failed to find server IP for given DNS!
Apr 13 19:55:53 (none) kernel: : Resource temporarily unavailable

The DNS specified in /etc/resolv.conf seems fine. At least it's pingable from the Tivo.

Maybe I need to check it's working. Telstra/Bigpond may have changed something.

Which file contains the address of the guide server? Should I use it's IP address or name and rely on the DNS?

Thanks Steve

13-04-2009, 08:58 PM
Quick update, looks like the bigpond DNS must have stopped working. I've updated with new addresses for their DNS's and the daily call is working again.

Thanks Peter - crisis averted.

Still the issue that perhaps I should be using the guide servers IP and not relying on the DNS (if I knew where it was stored) but of course that would assume the IP would never change?


14-04-2009, 02:46 AM
IP has changed only once in the last 7 or so years, but we still prefer people to use www.oztivo.net (http://www.oztivo.net) just in case we need to move servers or if there is a temporary issue with the current server.

If you did want to change it, it is stored in /etc/oztivo.conf


15-04-2009, 01:00 AM
Thanks Peter