View Full Version : wget Help

12-06-2004, 12:42 PM
Hi all,

I am having some problems getting my TiVo to talk to the emulator. I am using serial PPP connected to a windows XP laptop. I can telnet to the TiVo no problem and from the TiVo I can ping outside websites ok as well. SO this to me indicates that the networking side from the Tivo to the outside world is all ok, except when I try to wget it fails, or in fact just sits there forever until I cancel it.

[TiVo [p0] /var/log]# wget
=> `index.html'
Connecting to connected.
HTTP request sent, awaiting response...

I know there are issues with HTTP/0.9 web clients so I have tried a couple of things the test whether this is the problem:
1. download wget for windows and tried it - worked perfectly
2. tried to telnet (from windows as there is no telnet on the Tivo) to port 80 then issued the command 'GET / HTTP/0.9', which I understand sends a http/0.9 command to the server. This also appeared to work ok.
3. I have talked to my ISP (Iinet) and they claim that there in no cacheing or proxies in place in NSW (I am in Sydney) which should affect me.
4. Had port blocking turned off by the ISP (actually an option on their website to do it) as they were block port 80 incoming.
5. I am using a wireless setup from the laptop to a router then to a modem to access the internet via ADSL, so I have tried taking the router out of the equation just in case I missed anything in the setup.
6. Tried using another laptop with windows 2000 this time to do the serial PPP, just in case XP was the problem - still no success.

I have also tried changing the speed of the serial connection, but I am not sure that I did it right as it seemed to make things worse (ie I couldn't connect to the TiVo anymore) - what I did was go into Network Connections and then changed the properties of the Communications Cable between two computers to 57600. BTW when I do the dbget /State/PhoneConfig DialPrefix my TiVo returns ',#401' which I believe is correct.

I honestly don't know what else to try and would welcome any ideas at all.

If all else fails is it possible to manually download the files and transfer them to the TiVo and then fudge the Guided Setup, at least something like this could get my up and running.

12-06-2004, 05:49 PM
Hi Fletch,

Sorry, I'm no expert in this issue but I have seen this post on the mailing list ...


... which might be of interest.

Cheers, Dave.