View Full Version : Problems with Guided Setup

28-05-2004, 09:28 PM
I have had my Tivo for just over a week now and have tried everything to get it up and running. (I am a Tivo and Linux newbie - haven't hacked anything seriously since Dos 6.22)

I started with the " NZ TiVo Newbie? Start Here..." thread (thanks Jaidev and Tim) and managed to get the oztivo 3.1 image on and successfully networked it.
Then I tried the loadguide instructions (hadn't seen that the emulator was available). After editing and running all the tcls as per Tim's "Tivo Howto" I could not get past the Guided Setup. (I expected the Tivo to boot up and bypass the dial up because I read:

> Note that you don't need to do anything with the OzTivo guided setup
> onscreen because this is targeted for automating the setup to the OzTivo
> Service Emulator"
The Tivo insisted that I go through GS and then failed to connect.

Anyway, I eventually noticed the "Emulator available" thread (thanks Ed) so I re-imaged the disk (in case I had accidently hacked it to bits) and I followed Ed's instructions.

Again the Tivo fails to connect with the message "Failed. Service unavailable"

From the tivo I can successfully ping

A few other things I have noticed that may be important:

When I select "Logs" from the Tivo Web I get:

--cut here--
action_logs '/' ''
no files matched glob pattern "/var/log/O*"
while executing
"glob "$TIVO_ROOT/var/log/O*""
(procedure "::action_logs" line 20)
invoked from within
"::action_$action $chan $part $env"
("eval" body line 1)
invoked from within
"eval {::action_$action $chan $part $env}"
--cut here--

...before the list of logs displays.

The tvlog concerns me too - it has grown to about 172,000 records in the few hours I have had it on since re-imaging it. (With the old image it had built up to over 26 million records in about 5 days so I now switch the Tivo off unless I am working on it). I can't see any obvious error messages - mostly looks like debug information - but if anyone knows what I could look for I would be grateful.

Not sure if this matters but I do not have Sky (yet) - I have connected the Tivo to a VCR and want to try it out with Free To Air channels. I know I will need to sort out the IR codes but will cross that bridge later. Just using it as a manual recorder would be good to start with but I cannot get it to do anything.

Any hints would be much appreciated....

29-05-2004, 11:29 PM
I got past my "Failed. Service unavailable" by unplugging the tivo from my hub and plugging it directly into the ADSL modem.

I can now connect every time but have to re-connect via the hub in order to use telnet or tivoweb. Since my hub is downstairs and tv upstairs this is a pain.

The LAN is isolated from the modem by a standalone smoothwall firewall. Is there a trick to getting the tivo to work through a firewall?

30-05-2004, 08:38 AM
Have you tried to do a "wget" from your TiVo?

The syntax once you've telnetted into your box is:
wget http://ip.address/directoryIfOneExists/fileto.get

for example:

Might be a transparent proxy issue as well. I believe this was discussed on the OzTiVo mailing list.

Hope this helps.

30-05-2004, 02:00 PM
Thanks, tenty, for your hint - my Smoothwall was set up to provide a transparent proxy.

I have disabled the proxy and now the Tivo connects through the hub and firewall - no problem.