View Full Version : Moving from NZ legacy to current emulator

07-08-2006, 07:30 PM
I'm keen to see a sucessful test and document of the procedure for moving from the NZ legacy port 80 emulator, to the current port 8000 emulator.

As such we need a volunteer who is running on the legacy system to try it out the move, work the issues and post results.

Previously the logo slice on the new system has been a problem, but Warren from the Oz team has written a small tcl script that resets/removes logos. He reports success, but we haven't tried it on the NZ system.

Any takers?

08-08-2006, 11:47 AM
This is probably not at all helpful, but recently I suffered a major death of the mfs system, so my TiVo just had a rebuild. It was quite painless - thanks to thomson, and now - since I lost everything anyway - I'm back on the dev emulator :)

09-08-2006, 07:45 AM
I'm back on the dev emulator :)

Heh, ok thats one way, any others.. :P

Futher to DJC's post please document your procedure on the nztivo.net (http://www.nztivo.net) wiki...

09-08-2006, 10:55 AM
I'm currently on (the Legacy emulator).
I'll do the clear and delete everything test to move to the other emulator -

But first I'm (currenlty) FTP'ing off the kid's and wife's programmes - so I don't get myself in too much trouble.

I'll do the documentation also.

09-08-2006, 10:47 PM
A few months back when we had problems with Ed's emulator I got away with changing to the port 8000 emulator, grabbing the logo slice, then switching to port 80, which at the time was the active port, all without doing a clear and delete.
Just tried switching to port 8000 again, partly to get the MTV station listing and logo, partly to test the process, didn't do a clear and delete, got 'failed call' not surprising really! Switched back to port 80 again and all seems ok. Can't see when I'll be allowed to do a clear and delete this side of a HDD failure! Sons tivo has much less on it, so might have a go on that one.

10-08-2006, 09:16 AM
Tony sounds like you are in the configuration that we are trying to test moving from legacy to 8000. Except that you say you have logos from the 8000 emulator? Have you modified the logos by hand since?

Warren from oztivo has written script to remove all logos from a tivo, the tests that woudl be good to run are.

1. Remove logos from tivo, try 8000.

2. I'll remove the IR slice from the hidden dev emulator and you try to move to that (its a basically a copy of the main 8000 emulator we use for testing)

This will tell us where the problems lie and give some definitive answers to the community as to what we can and can't do in terms of switching. I guess if it goes west I'll have a look at manually editing the old headends.

Over to you really, always the (slim :rolleyes: ) chance of something going wrong.

10-08-2006, 09:30 AM
Set up of my two tivos is as follows:

Main tivo: Oztivo v1.4 image, running on legacy emu, logo's sourced from 8000 emu when that was dev. emu, no new logo's added by hand, but I have had to re shuffle them a couple of time when they all switched to cartoon network on their own! Lots of programmes, season passes etc ,so clear and delete not really an option. At some point I want to reimage with NZ image, but that won't happen till forced by a crash!

Son's tivo: NZ image, running on legacy emu (surprised that the NZ image points to port 80, didn't realise till last night) logo's sourced from port 80 I assume, as it's never been connected anywhere else! not much in the way of programmes etc on the drive, so a clear and delete isn't a big issue and if it all turns to custard, a reimage wouldn't be a major loss.

Let me know what you'd like me to do, I'm probably an ideal guinea pig, as I have enough knowledge to do the basics ie move emulators, re run GS etc, but not enough to do what I see as the difficult stuff like ftp'ing files onto tivo etc

More than happy to give it a go, I had a lot of help from the Oz/NZ tivo community, it'll be good to put something back in!

10-08-2006, 09:40 PM
Sounds like your sons tivo will be the ticket.

I'll PM you details on the hidden dev emu.

14-08-2006, 10:15 AM
Hey DJC...,

While TONYS is doing his test should I go ahead with a test of the 'clear and delete all' path?

I was going to get in right now and do it (after my pie for lunch), but then noticed your 'conversation' with TONYS.


14-08-2006, 11:05 AM
It going to be at least a few days before I have the time to do my test.........

14-08-2006, 11:19 AM
While TONYS is doing his test should I go ahead with a test of the 'clear and delete all' path?

Yep, get into it I reckon, more the merrier. Tonys is testing the non clear and delete path.

14-08-2006, 01:40 PM
OK, I've started... currently indexing after Guided Setup... I'll report in again when finished - or when I need assistance :)

14-08-2006, 03:06 PM
OK, done the move from port 80 to 8000, all looking good so far (just a time issue, resolved as below). Here are the steps I did:

1. FTP any required 'Now Playing' programmes off the TiVo (via MFS-FTP running on the TiVo)

2. Backup 'Season Passes' and 'Wishlists' via the TiVoWeb(Plus) 'Backup' module

3. Backup 'Channel Preferences' via the TiVoWeb(Plus) 'Channel Prefs' module

4. Select 'Clear and Delete Everything' from from the 'Messages and Setup / System Reset' TiVo menu

5. Put the TiVo into 'Maintenance Mode' by following these instructions:

6. Run 'Guided Setup' following these instructions (remembering to change the emulator port number!):

7. Check the time on your TiVo (have a look at, say, the Guide, on your TV screen), and the time via a telnet command prompt. If (like mine) the TV screen is wrong and the command prompt is correct then at the command prompt run "timezoneadj30.tcl" and select '7'.

You can also check if things are right by looking at http://<your-tivo-ip-address>/mfs/State/LocationConfig.
TimeZoneOld should be 7, and DaylightSavingsPolicy should probably be 0 (although it's probably not used).
If incorrect run the above command.

Don't forget to reboot.

8. Restore 'Channel Preferences' via the TiVoWeb(Plus) 'Channel Prefs' module (click 'Update Changes' at the bottom of the screen)

9. Restore Season Passes and Wishlists via the TiVoWeb(Plus) Backup module

10. FTP any 'Now Playing' programmes back onto the TiVo


14-08-2006, 08:09 PM
Hmmm, I am port 80 and am happy to move, is the clean, clear and delete necessary?

There are issues when you have a 250GB drive in you Tivo backing it up :p

14-08-2006, 08:30 PM
Hmmm, I am port 80 and am happy to move, is the clean, clear and delete necessary?
Well, maybe... it is until someone else tests another method that DJC and TONYS are talking about.

There are issues when you have a 250GB drive in you Tivo backing it up :p
Yes, I know what you mean - I have 2x200GB drives in my TiVo... luckily I only wanted 40GB of it (that took a touch over 10 hours to FTP to my PC and is proving many times slower the other way.

15-08-2006, 06:14 PM
Futher to DJC's post please document your procedure on the nztivo.net (http://www.nztivo.net) wiki...
Where would you like that done? Under Topics or FAQ? ... or...

15-08-2006, 06:27 PM
Let me know if you need another victim to test the delete logo script with a legacy system on :80


15-08-2006, 07:15 PM
Where would you like that done? Under Topics or FAQ? ... or...

Under Topics would be the place, named something appropriate.

17-08-2006, 12:35 PM
does this have an effect on my IR codes?

took me ages to get my IR codes going (motorola)

17-08-2006, 02:09 PM
does this have an effect on my IR codes?

took me ages to get my IR codes going (motorola)
I believe it does. Not that I really know because during the Guided Setup I just chose the OZTiVo-Motorola (not sure of spelling there) option, and it worked fine for my Motorola DTH325. Maybe I could have bypassed that but I don't know. I do know that people have given up making some model(s) of Motorola IR go. So if you fixed yours by running the supplied script on the NZTiVo website which has now been integrated into Guided Setup (or if it's the same model as mine), then I'm suggesting it'll be easy... otherwise you'd have to redo whatever you did to get yours going again (isn't anything like that only difficult the first time? - I say with my documentation hat on, the one that I get constant abuse for! :))

Hope that ramble gives you some confidence...:o

17-08-2006, 03:29 PM
The current emulator (port 8000) contains the oztivo IR slice. All those devices not in the original image are now added at guided setup. You can check the devices on the oztivo wiki (IR database).

When the new emualtor was setup our objective was to incorporate IR support for the various NZ specific set top boxes. I know we added support for motorola (which version?) and zenith boxes. The scripts came from the nztivo wiki.

If you have a different version of STB, you could take the codes you used, compare them to the IR database and incorporate into the database if you have some different version. The NZ system will grab the IR slice when it is updated.

17-08-2006, 06:16 PM
I know we added support for motorola (which version?) and zenith boxes. The scripts came from the nztivo wiki.

Don't know which version you added, but it works with a Motorola DTH325-n (n being 1 - 4, I think). The Motorola STB that people were having (possibly unresolved) trouble with was DTH335-4.

19-08-2006, 12:53 PM
I had an experiment with this... here's what I found

Installing a tivo onto port 80 (which can't normally be done) gave me a legacy test device.

Moving it to the port 8000 emulator gave the expected "failed preparing data".

Removing the logo slice made no difference. Further any manually placed logos can potentially be removed by script, thanks to Warren.

Removing the IR slice made the difference, once I'd removed the oztivo IR slice from the test emulator daily calls succeeded.

Manually trying to load the IR slice on a machine setup off an emulator without fails with a load error. So this is the failed preparing data issue, also verified this looking at the tclient logs as to which slice was failing.

There is a second problem, I suspect. Because the headend Id's have changed the unit came from the legacy AK02113 headend to the current NZ02113 headend. (AK is now reserved for the Auckland FTA setups)

This may also mean that data wont be loaded for those running the AK02113 headend once a switch is made, unless the tivo's primary headend is also changed to NZ02113 to match the emulator slices.

A step closer perhaps..

We need to:-

i) Find out how manually load the oztivo IR slice on a legacy tivo, the fix to this will sort out the failing daily call.

ii) Sort out how to change the primary headend to the new headend Id. A bit of MFS work I suspect.

Item (i) can be easily tested by anyone with a legacy setup by downloading the oztivo IR slice from here (http://minnie.tuhs.org/tivo-static/headends/IR-oztivo-v227.slice.gz) and trying to dbload it, at your own risk of course.

07-10-2006, 11:25 AM

Recently installed Tivo (about a week ago) using latest image.
Can someone please tell me the password for the web interface so I can enter guided setup, I http to it and get login prompts!#. The tivo is having trouble making a call. Networking seems to be OK since I can telnet to it. I've tried changing the GS=0 to GS=1 but it didn't work. I need to force it to make a call.
Help much appreciated

07-10-2006, 12:24 PM
Default password is "nztivo" for NZ TWP based images.

Edit: Infact I think that it is the default username is "nztivo" and the password is empty from memory.

07-10-2006, 03:29 PM
Thats done it. Thanx for that :cool: