View Full Version : warped clock

05-08-2006, 02:16 PM

I am having a terrible time with my TiVo

I thought that everything was OK but noticed that my free-to-air clock was 5 hours behind - I checked the FAQ guides and they indicated that maybe I had a warped clock, followed the procedure to check if I had a warped clock and I did find a line that said ---clock is warped--- - but then an entry says that if my problem occurred after April a warped clock could not be the issue

The FAQ gave some telnet instructions but as my Tivo is after April and as I do not understand telnet I did not go down that track

I thought that maybe my daily calls had been unsuccessful but I checked and a daily call was successful yesterday (Friday) pm at 3.42 - I then tried to force a daily call through the Tivo web project - but each time it failed with service unavailable - test calls failed in the same way.

I then decided to do my guided setup again as maybe there was a problem when I last did the guided setup - but the guided setup won't work now as I get service unavailable

I can access my Tivo through the tivo web project and I can ping it from my computer and I don't know why I can't get a setup call to work as they all worked before!

Any help would be really appreciated

05-08-2006, 05:06 PM
As you are aware from your PM to me the server must be down this afternoon as I cannot 'make the call' either and I know it's not my network and/or card etc.

Lets hope it comes back up soon as I want/need to get my tivo working again as it should.

Just thought I would post this if somebody else was having the same drama trying to make the daily call etc.

Darren King
05-08-2006, 05:23 PM
Just posted a "news" thread regarding the outage.

05-08-2006, 05:49 PM
Thanks Darren. I knew it was out but I am happy to hear it officially from you.


Darren King
05-08-2006, 06:41 PM
No problems :)

And I am happy to report it is now operational again.

Darren King
05-08-2006, 07:00 PM
Hi Trevor

Just in case you redo Guided Setup and still experience the warped clock messages this is not hard to remedy via telnet.

Grab yourself a copy of a program called PuTTY. This is a freeware program that will give you the ability to telnet. You can get it from here: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

Or just do a Google for: putty telnet

Once you have it you will need to change one of the settings in PuTTY. You will need to disable "Return key sends telnet New Line instead of ^M" in the Connection settings.

From the system menu select "Change Settings...".
Click on "Connection" in the Category window.
Deselect "Return key sends telnet New Line instead of ^M".
Click the "Apply" button.

Then all you need to do is enter in your IP address, ensure it is for Port 23 and select Telnet as your protocol. You should then see a telnet session with the TiVo bash prompt: [TiVo [p0] ~]#

Then just follow the instructions as per #6 of the instructions for fixing a warped clock

[TiVo [p0] ~]# touch /var/timestamp
[TiVo [p0] ~]# /hack/bin/force_index.tcl

While I am on the subject of the instructions for fixing a warped clock, nowhere does it say that you SHOULDN'T follow the instructions if you using R1.4 software after April (2005). You can still get the odd occurrance of a warped clock at any time. What it IS trying to point out by that statement is you are more likely to get it if that software release of the oztivo image was used.


05-08-2006, 10:16 PM
Thanks Darren

I will give the telnet thing a go tomorrow

You advise that it is operational again - but I have just tried the setup call and a test call again and I still get "service unavailable"

Everything looks fine at my end as I can access Tivo web project and I can ping my TiVo without problem??????

Darren King
05-08-2006, 10:29 PM
All works fine this way. Just tried several test calls and a manual download of guide data.... all worked fine.

05-08-2006, 10:32 PM
Yes I tried it twice and works fine after 8pm tonight.

05-08-2006, 11:45 PM
I rebooted the TiVo and the setup worked - thanks everyone

But my clock is still 5 hours behind - it says 07.35pm at 00.35am - I will try the telnet thing again tomorrow when I am more awake

Darren King
06-08-2006, 08:25 AM
After doing a Guided Setup it is not uncommon for the clock to be wrong.

Go into TiVoWEB and check the Phone menu. If you have the message that the last call attempt has succeeded and NOT still loading data or indexing shows then reboot the TiVo.

If the clock is still wrong you have problems. In which case first thing is to ensure that your router and/or firewall (whichever is applicable for your network) is not blocking port 37 which is used to adjust the clock.

06-08-2006, 09:34 AM
When I did my guided setup last night my clock was 5 hours short but of course after the hours of indexing I then rebooted and all was fine as far as the clock.

06-08-2006, 10:07 AM
Reboot fixed the clock - thanks for your help Darren

Darren King
06-08-2006, 02:56 PM
Good stuff.

Have you checked the logs and made sure you do not have a warped clock issue? Make sure just in case, as having the correct time on the visible clock is not a guarantee.