View Full Version : First Time Tivo Set-up - Can't Call Out

26-04-2006, 10:08 PM

I am a complete Tivo newbie, so I apologise in advance for any ignorance. I have recently purchased a philips series 1 HDRx12 tivo from the US with the hope of getting it running in Melbourne, Victoria. This unit came with no harddrive or network card. I have successfully installed a 120gb Seagate harddrive and a Turbonet network card (wasn't sure if this was required, but got one just in case!) using the links on this site.

I then successfully managed to load the iso image onto the harddrive (pretty sure this was the latest version as of last week), and I have connected the tivo to my TV via my digital foxtel box (I receive satalite foxtel), as I do not have a PAL tuner installed, and don't know where to purchase one. I have been told that this should still work (at least for the foxtel channels).

When I go through the guided setup, following the instructions from the Oztivo site, I get to the point where the tivo needs to make the first 'call out'. At this point, my tivo is connected to my TV and foxtel box via RCA cables, and I have a phone cable running from the back of my tivo to the phone socket. I have two main questions here:

1. The network card is currently not plugged into anything. I assume it should be, but I'm not quite sure what this is used for (told you I was new!). Should this be plugged into my modem or something?

2. When the tivo tries to call out (I presume using the phone line), the call does not connect. I have tried all the troubleshooting options, and have also tried to make a test call, which fails at the 'connecting' stage' (it passes the preparing to dial and dialing phases). The error message that is shown is 'service failure'. I definitely know that there is no problem with the actual phone line itself (it has recently been tested by a technician for an unrelated problem). In addition, even though it says that it has passed the 'dialing' portion of the test call, I never hear any dialling noises when I pick up the phone (on the same line), so I suspect that it is in fact, not dialing. Is the Tivo missing some piece of hardware that I need to connect perhaps? Or is this where the network card kicks in?

Sorry if I have been verbose or comepletely moronic. Any help that could be provided would be greatly appreciated. I have learnt a lot through trial and error as well as through these forums/FAQs, but it seems that I have hit a brick wall.

Thanks very much in advance!

26-04-2006, 11:37 PM
Hi and welcome to the group.

To proceed we need to know how you currently connect to the internet.


Darren King
27-04-2006, 01:10 AM
Peter is correct.

TiVo in Australia does not natively connect to the setup and guide data server via the internal modem like you might think it does in the USA. In Australia you need some sort of internet connection for it to work.

27-04-2006, 03:30 PM
I am currently connected to the internet via Optusnet broadband ADSL. My current setup is as follows:

- D-link 302G Modem, which is pluged into my phone socket; and
- Apple Airport wireless router, which is connected to my D-link modem via ethernet cable.

At present the tivo isn't connected to my router or my modem (my modem only has one ethernet port at the back, which is being used to currently connect to the wireless router). I thought that I might have to connect the turbonet card to the modem via ethernet, but I don't have a spare port at the back to do this. Is this the case? Or am I supposed to be just plugging in the phone line to the back of the tivo?

Sorry if this is confusing!

Darren King
27-04-2006, 05:07 PM
Go and buy a 4-port hub. Plug the ADSL modem into one port, the wireless Airport router into another of the ports and the TiVo via the turbonet card into another. This will get around your lack of spare ethernet ports and give you one spare for expansion later.

As previously said, you cannot use the modem internal to the TiVo in most cases. That is the short answer. The long answer is that you can, however given you already have ADSL then this is pointless given you will also need a dialup internet account and be prepared to spend money on about one phonecall a day. Why do that when you have the means to do it properly via your ADSL internet account which means you won't spend any money on phonecalls.

27-04-2006, 07:29 PM
So does this mean I don't need a phone line in the tivo at all? I will purchase an ethernet hub tomorrow and give that a try.

27-04-2006, 07:33 PM
I agree with Darren, in your case it is best forgetting about the TiVo modem, as you already have ADSL and a turbonet card.

As Darren has suggested go and get at least a 4 port hub or switch and 2 extra cat5 cables. Use your existing cable to connect the modem to the hub/switch and the new cables for the airpoint and tivo.

Turn the TiVo off.

Remove the HDD and put it back into your PC

Rerun the oztivo installer and setup the software for the turbonet. I'd suggest you set a static IP something like

When you finish setting it up, remove the HDD and reinstall it in the TiVo.

Then install the Turbonet card and run it's cable out the back of the chassis and plug it into your new hub/switch.

Turn the TiVo back on and try Guided setup again.


27-04-2006, 07:36 PM
So does this mean I don't need a phone line in the tivo at all? I will purchase an ethernet hub tomorrow and give that a try.

Correct, you will only use your existing ADSL connection and the TiVo modem will not be used.


27-04-2006, 09:10 PM
I just tried to set up the tivo using just the ethernet cable as follows:
The ethernet cable plugged into the turbonet card, with the other end plugged into the ethernet port of my modem.

The HDD is already set up with a static IP address. I then tried to run the guided setup again, and I still got no connection when it tried to connect. The error message that came up at the 'connecting' stage was as follows "Failed. Service Unavailable". I then ran the test the phone line option and got the same error message.

Any ideas?

Darren King
27-04-2006, 09:41 PM
Is the modem showing it has a valid ether net link - maybe a crossover cable needed?

Is the static IP address, subnet and gateway one that matches your modem?

If either of those check out what happens if you re-image the hard disk leaving it to the defaults of DHCP assigned?

At any rate you can FORGET about the internal modem. As stated, unless you have a dialup ISP and it just so happens to be compatible with the login method the TiVo requires to authenticate (not many ISP's do) then it is a waste of time even trying. For all intents and purposes the internal modem is useless in Australia.

Are you clear on the fact that with the internal modem TiVo in Australia does not dial a dedicated TiVo service like it does in the USA, rather it requires a compatible dialup ISP to network to the community emulator server via the Internet - just like to does via an ethernet connection and your ADSL modem?

27-04-2006, 09:47 PM
Ok, so I'm clear that I definitely don't require the internal modem. I don't have a PC handy at the moment, but tomorrow I will go and reimage my harddrive and use the DHCP option instead of the static IP address, and see if that helps.

I will post my results (successful or otherwise!)

Thanks again.

29-04-2006, 01:19 AM
Success! I re-imaged my HDD using a DHCP address and the connection worked no problem once I connected it to my modem. The tivo is now set up and ready to go! Thanks for your help on this.

I now have one more problem... The tivo's clock does not appear to be correct, and I have been through all the setup options on the tivo and have not found any option to correct this. At present, the tivo guide seems to be approximately 5 hours ahead of the actual tv schedule (I have checked this against the actual foxtel digital guide). So, a program that is actually scheduled in foxtel to screen at say, 6:00am, is listed in the tivo tv guide as screening at 1:00am.

Is there anything I can do to fix this?


29-04-2006, 01:46 AM
Is there anything I can do to fix this?

Yes, wait 12-24 hours for indexing to be completed and then reboot :D


10-05-2006, 11:02 PM
Hi Guys,

I tried to wait 24 hours and reboot my tivo, but my internet connection was cut off (long story). I stupidly went back into the maintenance mode to start the process again, and came up with the same problem as before (ie. can't connect). I have tried everything, including:

Re-installing the image on the hard drive (using DCHP and static IP addresses);
Replacing the ethernet cat-5 cable (and trying a cross-over cable as well);
Resetting the tivo (ie. powering off and then on); and
Resetting my modem/router (including getting a brand new modem).

In addition, I have had the line checked out by Telstra, who said it is fine.

I am now at a complete loss as it seemed to work once, but not ever again.

Any suggestions?

10-05-2006, 11:44 PM

At what stage is it now failing for you. Is it stopping at the first call home during GS?


11-05-2006, 12:02 PM
It's failling at the 'first call home' stage. Specifically at the 'Connecting' sub-step. Additionally, when I try and 'test my phone connection', it fails at the 'Connecting' sub-step there too (which is the third sub-step in the phone connection test).

11-05-2006, 12:36 PM
I suggest you run through NetworkingHowto#Configuration_and_Diagnostics (http://minnie.tuhs.org/twiki/bin/view/Network/NetworkingHowto#Configuration_and_Diagnostics) again and see what results you get.


11-05-2006, 05:01 PM

I'm really sorry to sound like an idiot, but I have read all of the networkinghowto page that you suggested, and I'm still having a bit of trouble seeing if my Tivo has an IP address.

I think this is partially because I am working on an Apple Powerbook rather than a PC (I have to travel home to my parents house in order to reimage my tivo's harddrive every time!).

Currently I have the tivo connected to an 8 port switch/ethernet port hub, which is connected to my DSL modem. My powerbook is also connected to this hub.

The OS X page mentions that I will be able to see when the tivo has acquired an IP address via the network utility, however I am unsure if I am just not seeing the IP address or it is not working (I'm not too familiar with this application).

In addition, the networking how to document refers to some ping and router commands to test if the tivo pings back. The 'network utilty' application has a function where you can ping a specific IP address (ie. you just enter the address and it will either send 10 pings or an unlimited number if you choose so). I think this does the same thing as the ping command detailed in the howto document, but I am not too sure.

Pete, I'm not sure if you are familar with Apple/OS X, however if you are, can you let me know what to do here (or even some generalised tips).

Also, can you please clarify something for me, the term 'box' seems to be used a lot in the howto document. Is this meant to be my computer? Or my modem?


11-05-2006, 07:46 PM

I'm really sorry to sound like an idiot, but I have read all of the networkinghowto page that you suggested, and I'm still having a bit of trouble seeing if my Tivo has an IP address.

Ok lets go through networking 101 :)

When you last installed the Image, did you setup a fixed IP or DHCP ?

I'll assume DHCP, becuase otherwise you should know the IP as you set it.

What is assigning the IP's in your network. Is it your Router or your powebook?

Most cases it is your router. I don't know the specifics for you router, but you need to make sure that DCHP server is turned on, and there should be a section that shows you what Ip's it has given out. From your setup their should only be two IP's. One for the Apple and one for the TiVo.

See if this narrows down your search for the IP.

Failing that upload ipscan14.exe (http://minnie.tuhs.org/twiki/pub/Uploads/WebHome/ipscan14.exe) and scan IP's in the same range as you Apple's IP.

Pete, I'm not sure if you are familar with Apple/OS X

I'm not.

Also, can you please clarify something for me, the term 'box' seems to be used a lot in the howto document. Is this meant to be my computer? Or my modem?

Depends on the context, point me to an example.


12-05-2006, 04:48 PM
Hi, sorry for the delay in my reply. When I imaged the harddrive, I set it as a DCHP address setting.

With regards to assigning IP addresses, I'm pretty sure that it is my modem/router (are they the same thing?). At any rate, my modem/router is a Seimens Speedstream 4200 (supplied by Optus).

I couldn't download the IP scan program (it was PC only), but I managed to find a similar program for Macs (IP Scanner), which scanned for all active IP addresses. It only came up with an IP address for my powerbook. I confirmed this by going into my router homepage and checking the activity log (I've learnt a bit from playing round on this thing over the past few days!) and saw the same IP address assigned to my computers MAC address (I think it was the MAC address, it was a 12 digit alphanumeric number).

So I guess at this point, it looks as though my tivos isn't being assigned a DHCP IP address.

Is there anything I can post that might help diagnose this problem? (eg. system logs, etc).

12-05-2006, 05:19 PM
I would probably be best to contact optus, and make sure the Seimens Speedstream 4200 is not just a modem, but a modem/router. Also get them to make sure DHCP server is enabled.


31-05-2006, 07:56 PM
Yes, the Seimens Speedstream is definitely a modem/router. I have been trying to get this going for weeks now and no luck. Do you know of anywhere I can take this tivo to get some hands on advice? I am just about ready to give up on the tivo and go buy a Topfield or a Foxtel IQ. :(

31-05-2006, 10:26 PM
How about just taking it to a friends house and try their ADSL.


Darren King
01-06-2006, 07:39 AM
Have you at least checked the modem setup? If it is a modem/router then it would be configurable and as Peter has mentioned you will need DHCP enabled in the modem, or at the very least determine the IP address range the modem works in (ie 192.168.x.x) and manually set the TiVo networking setup to an IP address in this same range.

05-07-2006, 08:47 PM
hey newbie.

okay i know im not pro at tivo just yet but i think i can help u out.
it just so happens i found someone at my school who also has a tivo (AH finally found someone who actually knew what a tivo was LOL) anywayz... they are with optus using a Seimens Speedstream 4200. i showed them this and said they has a few problems too.

firstly...as darren said...check your router set-up (192.168.x.x) definetly something to have a look at...see if DHCP is enabled in the IP Settings section.
secondly...set up a fixed ip on tivo...for some reasons sometimes the DHCP doesnt always work. i dont know why it just doesnt. justin (friend) just said that in the tivo networking he had it set on DHCP then switched it to a fixed ip and it ended up working.

hope this helps....lol i probably sound like some crazy fool who doesnt know what im on about =P just try it out...and keep trying....everything will end up working....tivo is one awesome piece of life.

anywayz....good luck! =)